2008 Redline with 12,000 miles is sick - Saturn Sky Forums: Saturn Sky Forum
Saturn Sky Forum Saturn Sky Forum
 
Go Back   Saturn Sky Forums: Saturn Sky Forum > Saturn Sky Discussion > Saturn Sky Redline Discussion
Register Home Forum  /  Current Posts Gallery Garage Search Today's Posts Mark Forums Read

Saturn Sky Redline Discussion Forum for discussion of aspects of the anticipated hi-performance version of the Saturn Sky.

SkyRoadster.com is the premier Saturn Sky Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools
Display Modes
Old 09-06-2016, 02:38 PM   #1 (permalink)
Member
 
Join Date: Apr 2014
Posts: 24
My Photos: (0)
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
2008 Redline with 12,000 miles is sick

Hello all. I need some help. I have a 2008 Sky Redline with only 12,000 miles on her. I am the second owner and have owned the car for a couple of years. I have been having this intermittent problem and cannot seem to determine what is causing it to solve it.

In the two years I've owned the car, this has happened three times. I can drive the car for about an hour. Shut it off and go into some place for approximately an hour. Come out and start the car and it acts all crazy. It throws several codes and goes into limp mode.

It happened again yesterday. We drove the car down to Huntsville, AL and went into a place to eat. When we came back out and started the car, it ran like crap. It threw codes and the service engine light came on. It also said to service the traction control system. It threw the following codes:

P2119 - Throttle Actuator Control Throttle Body Range/Performance
P2544 - Torque Management Request Input Signal A
C0561 - ABS Module RAM/ROM Circuit

I didn't have any tools with me, so we limped to a tool store and I bought some wrenches and took the battery cables off. They had corrosion, so I cleaned them and put lithium grease on the posts. I thought maybe this might be the cause. Put it back together and same problem. I pulled fuses and modules to see if anything was blown and all looked good. We limped to an Advance Auto Parts store and I got a scanner and erased the codes in the computer. Started the car back up and it ran fine all the way home (about an hour's drive). Shut the car off in the driveway for about 30 minutes. Started her back up to pull her in the garage and it ran like crap again.

Anyone know what these codes might be the symptoms of? I hate to take it to the dealer because I'm afraid they'll be stabbing in the dark trying to troubleshoot the problem and it will cost me a fortune.

Thanks,
Darrell
Daydk1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-06-2016, 02:50 PM   #2 (permalink)
Senior Member
 
TomatoSoup's Avatar
 
Join Date: Nov 2009
Location: Gaithersburg, MD
Posts: 3,162
My Photos: (0)
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
I would suggest that you simply need a new battery.

One: these weird electrical problems are classic old/bad battery symptoms - ours cars do really weird sh... stuff with a bad supply.
Two: corrosion around the terminals often happens with outgassing from an old battery.
Three: the symptoms are happening more often as the battery gives up the ghost. Pretty soon it'll fail stone dead.

You could get it tested to verify, but often the tests pass, even though the battery is bad (false negative). Just change it.
__________________
Owner of "Campbelle", a Brazen 2008 GXP ... with mods piling up...
TomatoSoup is offline   Reply With Quote Quick reply to this message
Old 09-06-2016, 03:01 PM   #3 (permalink)
Super Moderator
Lifetime Supporting Member
 
Robotech's Avatar
 
Join Date: May 2006
Location: Temecula, CA
Posts: 7,568
My Photos: (1)
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 699 Post(s)
Garage
Once again, TS is probably pretty spot on here. Our cars get possessed with issues like this when the battery is on it's way out. I've never owned another car that is like this...

With the corrosion and how little the vehicle has been used, it would make total sense.
__________________

V.A.L. (#1108)
2007 2.4 Base
MagnaFlow dual outlet, quad tip exhaust test car
**Sold**

Max (#1547)
2007 TURBO 2.4
Too much to list here. See my Garage for details.
Robotech is offline   Reply With Quote Quick reply to this message
Old 09-06-2016, 09:40 PM   #4 (permalink)
Member
 
Join Date: Apr 2014
Posts: 24
My Photos: (0)
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks all. I will try a new battery. It is my understanding that you have to take the lower fender skirt off to get the battery out. Is that correct?
Daydk1 is offline   Reply With Quote Quick reply to this message
Old 09-07-2016, 09:15 AM   #5 (permalink)
Member
 
Join Date: Apr 2014
Posts: 24
My Photos: (0)
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Any suggestions on a particular battery? Should I go back with AC Delco for GM or just go with any good battery from Advance Auto Parts or Auto Zone?

Quote:
Originally Posted by TomatoSoup View Post
I would suggest that you simply need a new battery.

One: these weird electrical problems are classic old/bad battery symptoms - ours cars do really weird sh... stuff with a bad supply.
Two: corrosion around the terminals often happens with outgassing from an old battery.
Three: the symptoms are happening more often as the battery gives up the ghost. Pretty soon it'll fail stone dead.

You could get it tested to verify, but often the tests pass, even though the battery is bad (false negative). Just change it.
Daydk1 is offline   Reply With Quote Quick reply to this message
Old 09-07-2016, 09:47 AM   #6 (permalink)
Senior Member
 
Join Date: Nov 2009
Posts: 542
My Photos: (1)
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Garage
Quote:
Originally Posted by Daydk1 View Post
Any suggestions on a particular battery? Should I go back with AC Delco for GM or just go with any good battery from Advance Auto Parts or Auto Zone?
Better stick to AC Delco.....Not because they make the best but because even the best can sometimes be the worst (and they cost quite a bit more).

On a sidenote everyone i know who owns a 2007/2008 model seems to have changed battery at least once....I have yet to change it on my 2009 model so am i damn lucky or did they use different batteries in the 2007-2008 models ?
NikK is offline   Reply With Quote Quick reply to this message
Old 09-07-2016, 10:04 AM   #7 (permalink)
Senior Member

 
stungjoe's Avatar
 
Join Date: Jul 2016
Location: South O' Dallas
Posts: 444
My Photos: (0)
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
Fender has to come off. My 2008 had it's battery replaced by previous owner 2 years ago w/ AC-DELCO. When my Norm's fenders get here I will go ahead and replace it again just to be on the safe side.
stungjoe is offline   Reply With Quote Quick reply to this message
Old 09-07-2016, 11:52 AM   #8 (permalink)
Member
 
Join Date: Jun 2016
Location: Englewood Fl
Posts: 20
My Photos: (0)
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Send a message via AIM to fljohnboy
I had a Pontiac Gran Prix had the same issue. Replaced battery and all was fixed.
fljohnboy is offline   Reply With Quote Quick reply to this message
Old 09-07-2016, 12:18 PM   #9 (permalink)
Senior Member
 
08BlueSky's Avatar
 
Join Date: Mar 2008
Location: Pittsburgh PA (South Hills)
Posts: 745
My Photos: (0)
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Garage
Pull the Fender



Just watch the TOP POSTS on the Cross Member
__________________
(all) DDM braces - Catch Can - Clamps & Tune, Windrestrictor V1, Dual Horns, Red Calipers, Footwell & Trunk Lights, Front Side Marker/Turn Signal Mod, Side Fender Vent/Turn Signal Lights.
08BlueSky is offline   Reply With Quote Quick reply to this message
Old 09-07-2016, 02:24 PM   #10 (permalink)
Senior Member
 
ChopTop's Avatar
 
Join Date: Sep 2013
Posts: 499
My Photos: (0)
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 61 Post(s)
FWIW, there are several how to replace battery videos on YouTube.

https://www.youtube.com/results?sear...er+replacement
ChopTop is offline   Reply With Quote Quick reply to this message
Old 09-07-2016, 05:54 PM   #11 (permalink)
Senior Member
 
TomatoSoup's Avatar
 
Join Date: Nov 2009
Location: Gaithersburg, MD
Posts: 3,162
My Photos: (0)
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Quote:
Originally Posted by Daydk1 View Post
Any suggestions on a particular battery? Should I go back with AC Delco for GM or just go with any good battery from Advance Auto Parts or Auto Zone?
A common (and often heated) discussion. Personally I would go with the cheapest battery you can find that has a 3yr replacement warranty. The warehouse stores often have cheaper ones (Sams Club, Costco etc). My opinion post

See also: Need a new battery? Group 25 will fit! (x-post) - Pontiac Solstice Forum
__________________
Owner of "Campbelle", a Brazen 2008 GXP ... with mods piling up...

Last edited by TomatoSoup; 09-07-2016 at 05:56 PM.
TomatoSoup is offline   Reply With Quote Quick reply to this message
Old 09-08-2016, 12:28 PM   #12 (permalink)
Senior Member
 
08BlueSky's Avatar
 
Join Date: Mar 2008
Location: Pittsburgh PA (South Hills)
Posts: 745
My Photos: (0)
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Garage




Granted it's hard to get a good measurement photo of the Post heights due to camera/lens angles.







My Original Battery (2008) Been cleaning off (Positive) Top Post every year the past few years. I've also been using a Batteryminder 2012 on it for 3 years now thru the winters.


(and dang, PHOTOBUCKET IS MIGHTY SLOW) - can there be a better way to post photos?????
__________________
(all) DDM braces - Catch Can - Clamps & Tune, Windrestrictor V1, Dual Horns, Red Calipers, Footwell & Trunk Lights, Front Side Marker/Turn Signal Mod, Side Fender Vent/Turn Signal Lights.
08BlueSky is offline   Reply With Quote Quick reply to this message
Old 09-08-2016, 12:55 PM   #13 (permalink)
Super Moderator
Lifetime Supporting Member
 
Robotech's Avatar
 
Join Date: May 2006
Location: Temecula, CA
Posts: 7,568
My Photos: (1)
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 699 Post(s)
Garage
Quote:
Originally Posted by 08BlueSky View Post
(and dang, PHOTOBUCKET IS MIGHTY SLOW) - can there be a better way to post photos?????
You can either make them attachments (then link to them like I do on occasion) or get your own web server (through like Yahoo or GoDaddy...they can be as cheap as $5 a month) and upload them there then link to them. This is the way I do MOST of my picture posts.
__________________

V.A.L. (#1108)
2007 2.4 Base
MagnaFlow dual outlet, quad tip exhaust test car
**Sold**

Max (#1547)
2007 TURBO 2.4
Too much to list here. See my Garage for details.
Robotech is offline   Reply With Quote Quick reply to this message
Old 09-08-2016, 01:28 PM   #14 (permalink)
Senior Member
 
davhamm's Avatar
 
Join Date: Aug 2013
Location: SE Mi
Posts: 814
My Photos: (0)
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 248 Post(s)
Quote:
Originally Posted by Robotech View Post
You can either make them attachments (then link to them like I do on occasion) or get your own web server (through like Yahoo or GoDaddy...they can be as cheap as $5 a month) and upload them there then link to them. This is the way I do MOST of my picture posts.
Wait, this site will host our photo's? Personally think that is the best way as they will always be here. I hate it when I find an old thread here that has what I am looking for but the photo links are Dead.

Trying with pic of my Corvair. (sold it last year)

Attached Thumbnails
2008 Redline with 12,000 miles is sick-20140816_094114.jpg  
__________________
I am a GM Engineer.

I do not claim to be a GM representative, all of my postings are my own interpretation and personal opinions.

2009 HYDRO REDLINE AUTO
davhamm is online now   Reply With Quote Quick reply to this message
Old 09-08-2016, 01:47 PM   #15 (permalink)
Super Moderator
Lifetime Supporting Member
 
Robotech's Avatar
 
Join Date: May 2006
Location: Temecula, CA
Posts: 7,568
My Photos: (1)
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 699 Post(s)
Garage
Yep...though I don't know what limitations there are.



Saw this on the road this morning. Corvette Chassis. Pictures don't do it justice.
Attached Thumbnails
2008 Redline with 12,000 miles is sick-20160908_081728_1473356819169.jpg  
Robotech is offline   Reply With Quote Quick reply to this message
Reply

  Saturn Sky Forums: Saturn Sky Forum > Saturn Sky Discussion > Saturn Sky Redline Discussion

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Saturn Sky Forums: Saturn Sky Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Auto Insurance
» Recent Discussions
F/S ERepairables 09...
04-21-2017 08:04 PM
by ChopTop
Last post by skersfan
Today 09:40 PM
41 Replies, 771 Views
Trifecta Base and GMPP...
04-26-2017 06:42 PM
by davhamm
Last post by Taz
Today 09:35 PM
17 Replies, 295 Views
sky badges
04-23-2017 01:12 PM
Last post by DaveOC
Today 09:24 PM
17 Replies, 421 Views
Is anyone using one of...
Today 11:22 AM
by Taz
Last post by Taz
Today 09:23 PM
12 Replies, 169 Views
What did you do to your...
11-10-2009 10:23 AM
by NormSky
Last post by Windancer
Today 08:53 PM
3 Replies, 222,458 Views
Which Battery Maintainer...
04-03-2017 11:50 AM
by GJinNY
Last post by davhamm
Today 08:23 PM
22 Replies, 562 Views
Two More
Today 08:01 PM
Last post by Wind Restrictor
Today 08:01 PM
0 Replies, 23 Views
Exhaust Question
Today 10:27 AM
Last post by tompass
Today 05:42 PM
9 Replies, 131 Views
My Review of the Dr....
04-10-2017 08:49 PM
by MattM
Last post by mmartin
Today 04:03 PM
22 Replies, 580 Views
Opel GT/G2X badges
Today 11:52 AM
Last post by jburbs22
Today 03:21 PM
4 Replies, 80 Views
Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:33 PM.



Powered by vBulletin®. Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.