Service Air Bag - no A/C: dealer unable to diagnose - Saturn Sky Forums: Saturn Sky Forum
Technical Saturn Sky Discussion Technical and performance aspects of the Saturn Sky Roadster. Sky Problems | Solutions | Repairs | Recalls | Tech Bulletins | Tech Tips | In the Manual Basic Tech

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 11-28-2012, 08:12 PM Thread Starter
Member
 
'ula lani's Avatar
 
Join Date: Sep 2008
Location: Texas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Service Air Bag - no A/C: dealer unable to diagnose

I've looked at the other threads on the 'Service Air Bag' issues but my specific problem doesn't exactly match; here's the scoop:

Took my '08 RL in to the dealer b/c it had the overheating symptoms described by others on this forum. At the same time, my battery died so I jumped it to get to the dealer to drop it off. With a week business trip on the calendar, I asked them to look at the overheating issues and replace the battery. The water pump was failing and was replaced as well as the battery. On the way home after picking it up, the Service Air Bag light came on and the A/C went off. The airbag icon did not come on. I immediately returned to the dealer. After leaving it there for another week while on yet another biz trip, they diagnosed it as a pinched wire from the battery replacement. Picked it up and didn't even get out of the parking lot before the Service Air Bag message popped up and A/C controls quit. I left it there again and they gave me a loaner. Picked it up today and they blamed the issue on the harness being moved when I had VDI doors installed (year and a half ago?). Drove it to a meeting about 10 miles away and no message. Got back in after meeting and message popped up again

Symptoms: Service Air Bag message appears and A/C controls do not work, info center is locked by the message. Occasionally, the airbag icon appears resulting in the A/C controls and info center working again.

Anybody have this issue? Cause? Fix? HELP!
'ula lani is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 11-28-2012, 08:34 PM
Senior Member
 
Join Date: Oct 2007
Location: Parker Colorado
Posts: 3,553
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Very odd. Many of us have VDI and no issues.

Is the airbag alert for the passenger? Does it properly sense an adult?

My AC quit working due to low coolant pressure. Does the fan come on? Or are the controlls totally dead?

If the fan and heat function but the AC push button does not work, have the charge checked. If the pressure drops below the set minimum the AC is disabled.

If you have no fan or heat, look for an electrical problem.. The two faults may be totally unrelated
Rob the Elder is offline  
post #3 of 9 (permalink) Old 11-28-2012, 09:02 PM
Senior Member
 
lllfly's Avatar
 
Join Date: Apr 2009
Location: Elizabethtown, PA
Posts: 2,206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
Ck all the fuses on ecm,BCM.
Ck that they are pushed in tight.
Inc. all relays.
LLLFLY

08 PW R/L 5-spd,The Wolf
Goodyear Blimp flight 2010 NASSM
Best of Show Old Bridge,NJ 2011
Best Interior 2012 NASSM
2nd American Legends 2013
DDMWORKS Loaded, Wind Restrictor
lllfly is offline  
post #4 of 9 (permalink) Old 11-29-2012, 08:51 AM Thread Starter
Member
 
'ula lani's Avatar
 
Join Date: Sep 2008
Location: Texas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Service Air Bag issue cont'd

I'm not buying the VDI connection either, it is just the last thing they looked at that made it work for a little while longer. Same thing happened this morning, drove it 15+ miles as it appeared normal, stopped for coffee, got back in after 30 minutes and the Service Air Bag message immediately appeared and no A/C controls.

Airbag is alert for the passenger and properly senses an adult ... when the Service Air Bag message isn't on. I mentioned the PSS airbag issues to the dealer so they are aware.

The A/C controls completely die - no fan, no lights on the control dials. Occasionally, they come back on when the airbag warning indicator icon pops up.

The dealer claims they have checked all the ECMs and SCMs, harnesses and fuses for electrical problems. They have cleaned and re-seated the connections to make sure they are tight. All the signs point to an electrical problem but where is the problem source? Did not have this problem before they changed the battery - any ideas on how that might be relevant to a cause?

'ula lani is offline  
post #5 of 9 (permalink) Old 11-29-2012, 09:40 AM
Senior Member
 
Join Date: Oct 2007
Location: Parker Colorado
Posts: 3,553
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
If all else fails, reboot the car. Pull the battery terminal for 30 minutes and reinstall it. It is possible they got some strange transient when the rebooted the car that put it into a mode creating this problem.

If they really did all that they say they did, which I have no reason to doubt, then it has to be something very esoteric like a voltage spike during the reconnect that put the ECM . BCM into a mode it does not like.

Solstice Service - Jump Start Procedures - Pontiac Solstice Forum
Rob the Elder is offline  
post #6 of 9 (permalink) Old 11-29-2012, 07:20 PM Thread Starter
Member
 
'ula lani's Avatar
 
Join Date: Sep 2008
Location: Texas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Same problem this morning so I dropped it off this afternoon. I'll pass along Rob's suggestion if they call and tell me they still can't pinpoint the problem. I'll post updates here.
'ula lani is offline  
post #7 of 9 (permalink) Old 11-30-2012, 02:37 PM Thread Starter
Member
 
'ula lani's Avatar
 
Join Date: Sep 2008
Location: Texas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Diagnosis

Picked the car up today and so far so good.

Dealer Diagnosis: open circuit from run/crank relay to BCM in underhood fuse block
'ula lani is offline  
post #8 of 9 (permalink) Old 12-01-2012, 11:02 AM
Administrator
 
Bogie's Avatar
 
Join Date: Aug 2007
Location: Northern, VA
Posts: 5,831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by 'ula lani View Post
Dealer Diagnosis: open circuit from run/crank relay to BCM in underhood fuse block
Ask what part was removed to replace the battery. Standard way is to take off the fender.....but it's also accessible by removing/relocating the fuse block. In fact, I believe the block method is quicker/easier if you know what you're doing. Could just be coincidence, but if the battery is replaced via the fuse block method, and then on return there is an error related to fuse block that wasn't there before bringing it in.....

2008 Redline Auto
Born 7/20/07
Snagged 8/31/07
Released 8/8/15
Bogie is offline  
post #9 of 9 (permalink) Old 12-02-2012, 11:05 AM
Senior Member
 
carnut122's Avatar
 
Join Date: Aug 2012
Location: Waleska, GA
Posts: 349
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Bogie View Post
Ask what part was removed to replace the battery. Standard way is to take off the fender.....but it's also accessible by removing/relocating the fuse block. In fact, I believe the block method is quicker/easier if you know what you're doing. Could just be coincidence, but if the battery is replaced via the fuse block method, and then on return there is an error related to fuse block that wasn't there before bringing it in.....
^^^^^^^^^^^^That makes the most sense to me.^^^^^^^^
carnut122 is offline  
Sponsored Links
Advertisement
 
Reply

  Saturn Sky Forums: Saturn Sky Forum > Saturn Sky Discussion > Technical Saturn Sky Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Saturn Sky Forums: Saturn Sky Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome