P0230 /p0366 - Saturn Sky Forums: Saturn Sky Forum
General Saturn Sky Discussion Forum for discussing general topics on the Saturn SKY.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-27-2019, 12:03 AM Thread Starter
Member
 
Join Date: Jun 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
P0230 /p0366

Ive been having a couple issues. Last year my check engine light came on with code P0366 Cam shaft position sensor circuit range performance bank 1. I replaced both but I still get the code.

The other issue - Im getting the code P0230 Fuel pump primary circuit. After the car warms up its starts to misfire when I accelerate and had died two different times when I came to a stop. The misfiring isn't every time but continues to happen. I changed both the Intake and Exhaust solenoids, the 4 spark plugs and regularly put cleaner in the gas tank. I still have the problem and don't know why. Any ideas ?? Really hope this is a simple fix
HeyMikey is offline  
post #2 of 4 (permalink) Old 06-27-2019, 06:48 AM
Moderator
 
JohnWR's Avatar
 
Join Date: Aug 2006
Location: Lexington, KY
Posts: 4,555
Mentioned: 37 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Does the P0366 indicate immediately after starting the engine, or does it take several minutes to illuminate the MIL?

P0230 indicates a problem in the fuel pump relay control circuit and can be a short to ground, short to voltage or open circuit.
Reading the code should indicate which of these problems is occurring.

Just to clarify: You have changed the solenoids and the sensors? P0366 indicates a problem with the sensor.

These are both electrical or wiring problems. Has anything happened to the wiring in the car? You might try unplugging and reconnecting the ECM.
Look for damaged wiring around the engine and also check all of the connectors to make sure they are tight.

As a side note, I would not use fuel system cleaner on any kind of regular basis. Or ever.

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is online now  
post #3 of 4 (permalink) Old 06-27-2019, 09:33 AM Thread Starter
Member
 
Join Date: Jun 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The engine light does not come on right away.

Yes I changed both solenoids and position sensors

I have checked the wires I can see and all connectors. The only thing is the little plastic part that locks the connector onto the solenoids has broke off but those have a pretty good suction connect and doesn't seem like its coming loose at all.

I was YouTubing ECM. What do you suggest is the best way to reset it ??
Attached Thumbnails
Click image for larger version

Name:	IMG_9493.jpg
Views:	11
Size:	310.2 KB
ID:	105445   Click image for larger version

Name:	IMG_9494.jpg
Views:	11
Size:	333.8 KB
ID:	105447  
HeyMikey is offline  
post #4 of 4 (permalink) Old 06-27-2019, 11:19 AM
Moderator
 
JohnWR's Avatar
 
Join Date: Aug 2006
Location: Lexington, KY
Posts: 4,555
Mentioned: 37 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
I think you are going to need a Tech2 or equivalent to do a true diagnosis.

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is online now  
Reply

  Saturn Sky Forums: Saturn Sky Forum > Saturn Sky Discussion > General Saturn Sky Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Saturn Sky Forums: Saturn Sky Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome