Rust on a 08' RL - Saturn Sky Forums: Saturn Sky Forum
General Saturn Sky Discussion Forum for discussing general topics on the Saturn SKY.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 09-05-2008, 12:11 PM Thread Starter
Senior Member
 
SR819's Avatar
 
Join Date: Jul 2008
Location: Colonial Heights Virginia
Posts: 577
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Rust on a 08' RL

I was cleaning my Rl the other day and opened my trunk to dry it off and Bam!! 2 screws on the inside had visible rust. I had an appointment to have my drivers side seatbelt replaced the next day so I showed the service tech what I was talking about, and he said this was due to Saturn not using galvinized screws in production and that it was normal. What?? 1100 miles and rust is normal. I called bull**** and told them toreplace them and any others I might have missed. This is my second SKY and my 1st had no rust at all so my question is has anyone else seen this on their cars and or heard of this being common?

Hers--RIP
07' Sunburst2.4l
2-14-07
3 pedals

Mine

08' Carbon Flash SE RL
6-4-08
3 pedals
No Goofy Spoiler
Vin# who cares

http://imsaturn.com/profile/sr819]
SR819 is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 09-05-2008, 02:09 PM
Member
 
Join Date: Feb 2008
Location: Clearwater, FL
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
yep, I've got the same thing, and to the tech's credit...yeah that is probably normal. If they don't use galvanized or stainless hardware, you will get rust sooner rather than later, especially if you live in a humid, high salt water area. The real issue is whether it is acceptable or not...and no...it most certainly is not.
Juleric is offline  
post #3 of 20 (permalink) Old 09-05-2008, 05:02 PM
Senior Member
 
SHiNY's Avatar
 
Join Date: Apr 2008
Location: Long Skyland, NY
Posts: 1,565
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have exactly the same thing on mine. I wasn't sure if it was just me, now I know its not. I too noticed it after washing the car. Not sure if it's something they will replace but it certainly looks disgusting. Oh, and mine started rusting at about 3,000 miles.

Quote:
Originally Posted by roadsterrage View Post
Always happy to help you get your kink on, Reed.

___________________________________________
Not a fan of hypocrisy. Am a fan of NON-MASSC
SHiNY is offline  
Sponsored Links
Advertisement
 
post #4 of 20 (permalink) Old 09-05-2008, 06:14 PM
Member
 
Bogie's Avatar
 
Join Date: Aug 2007
Location: Northern, VA
Posts: 5,831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Yep, I have the rust. Have had it since I can remember. It's either a cost savings move, a mix up, or bad supply. I too think it looks bad, and reflects badly on the make. At a minimum they should use galvanized at the visible points.

2008 Redline Auto
Born 7/20/07
Snagged 8/31/07
Released 8/8/15
Bogie is offline  
post #5 of 20 (permalink) Old 09-06-2008, 08:44 AM
Senior Member
 
rich71's Avatar
 
Join Date: Sep 2007
Location: central new york
Posts: 290
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
i don't have rust there yet. so far my car hasn't even been touched by a sprinkle and isn't driven in the winter. i have only done a full wash 2x since i got it and just deatail it(dust it) with detailer and microfiber cloth....that being said, i had the windows down while cleaning the inside door panel, and i noticed all the screws that appear to be holding the rubber squeegee seal to the door showed ALOT of rust and had streaks of rust. What else is slowly returning to nature that we can't see??? Stupid move by GM AGAIN. if they can't up for galvanized, geeze at least spray some paint on the dam things

2007 Midnight Blue Redline
Manual Trans
Westers Race Tune
Hahn Intercooler
GMPP Catback Exhaust
ReBar
DDM Race Backbone Brace
JPM Shifter
Sprint Booster
K&N Filter
Stubby Antenna
Redline overlay on 3rd brake light
BMW LiftPucks 4the BLIND
rich71 is offline  
post #6 of 20 (permalink) Old 09-06-2008, 09:14 AM
Senior Member
 
xmicro_Redline's Avatar
 
Join Date: Dec 2006
Location: Beautiful Las Vegas, Where everyday is a sunny one
Posts: 5,438
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Can someone post a picture of this rust, this way those of us that have not noticed this can check. More upsetting was a picture I remember seeing on here of TWIRPS dash removal and the FRAME OF THE CAR was rusting under the dash. The pictures are removed from the thread, but here it is.

Hey TWIRP, do you still have those pictures???

https://www.skyroadster.com/forums/f2/frankensky-11726/


I think he cleared the thread because of issue with his gauges he was putting in.
xmicro_Redline is offline  
post #7 of 20 (permalink) Old 09-06-2008, 08:02 PM
Senior Member
 
SHiNY's Avatar
 
Join Date: Apr 2008
Location: Long Skyland, NY
Posts: 1,565
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by xmicro_Redline View Post
Can someone post a picture of this rust, this way those of us that have not noticed this can check.
The magnetism that is Reed busted my camera! We are going to take some pictures tomorrow (with his camera) so I'll see if I can post some for you.

Quote:
Originally Posted by roadsterrage View Post
Always happy to help you get your kink on, Reed.

___________________________________________
Not a fan of hypocrisy. Am a fan of NON-MASSC
SHiNY is offline  
post #8 of 20 (permalink) Old 09-06-2008, 08:34 PM
Member
 
Join Date: Mar 2006
Posts: 2,602
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Quote:
Originally Posted by xmicro_Redline View Post
I think he cleared the thread because of issue with his gauges he was putting in.
Looks like he cleared most of his posts. Damn shame, and we're poorer as a result. Just can't please everyone.


Back on topic...
I looked around but dont see any rust. Would like to see someone's pics showing it. Doubt I'll find any though as the car is in a hot dry climate in SoCal.
cerberus is offline  
post #9 of 20 (permalink) Old 09-07-2008, 01:44 AM
Senior Member
 
xmicro_Redline's Avatar
 
Join Date: Dec 2006
Location: Beautiful Las Vegas, Where everyday is a sunny one
Posts: 5,438
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by cerberus View Post
Looks like he cleared most of his posts. Damn shame, and we're poorer as a result. Just can't please everyone.


Back on topic...
I looked around but dont see any rust. Would like to see someone's pics showing it. Doubt I'll find any though as the car is in a hot dry climate in SoCal.
That sucks, some people need to not be so damn sensitive.

Thanks Karen, pics would be great!
xmicro_Redline is offline  
post #10 of 20 (permalink) Old 09-07-2008, 06:36 AM Thread Starter
Senior Member
 
SR819's Avatar
 
Join Date: Jul 2008
Location: Colonial Heights Virginia
Posts: 577
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I'm a bad newbie. i did not take any photos. I know these threads are worthless witout photos; my apologies to all..

Hers--RIP
07' Sunburst2.4l
2-14-07
3 pedals

Mine

08' Carbon Flash SE RL
6-4-08
3 pedals
No Goofy Spoiler
Vin# who cares

http://imsaturn.com/profile/sr819]
SR819 is offline  
post #11 of 20 (permalink) Old 09-07-2008, 06:43 AM
Senior Member
 
SHiNY's Avatar
 
Join Date: Apr 2008
Location: Long Skyland, NY
Posts: 1,565
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by cerberus View Post
Back on topic...
I looked around but dont see any rust. Would like to see someone's pics showing it. Doubt I'll find any though as the car is in a hot dry climate in SoCal.
You have a good point. However, my car is garage kept and barely sees rain. I think she has been in the rain about 4 times. I believe it is mostly from when I wash her. I have washed her about twice a week since I got her. After I'm done if I open the trunk there is a pool in I believe what people have referred to as the water drain? (Sorry I'm not very technical) That's why I make sure after I wash her now I take out the leaf blower and get the water out of all the grills and head/tail lights.

I actually mentioned it to Morfious the other day because we were washing our cars together but he said his didn't have the rust, maybe because it is a solstice and the trunks are designed slightly differently?

Quote:
Originally Posted by roadsterrage View Post
Always happy to help you get your kink on, Reed.

___________________________________________
Not a fan of hypocrisy. Am a fan of NON-MASSC
SHiNY is offline  
post #12 of 20 (permalink) Old 09-07-2008, 08:46 AM
Senior Member
 
SHiNY's Avatar
 
Join Date: Apr 2008
Location: Long Skyland, NY
Posts: 1,565
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ok here are some pictures. This view is the driver's side of my car which is a little worse than the passenger one...



Quote:
Originally Posted by roadsterrage View Post
Always happy to help you get your kink on, Reed.

___________________________________________
Not a fan of hypocrisy. Am a fan of NON-MASSC
SHiNY is offline  
post #13 of 20 (permalink) Old 09-07-2008, 10:22 AM
Member
 
Bogie's Avatar
 
Join Date: Aug 2007
Location: Northern, VA
Posts: 5,831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Yep, same rust for me. Note those screws are just above the trunk water channel, so anytime you're driving in rain or washing the car they will be subject to water moisture.

I'd recommend next time you run down to the hardware store to pick you up a galvanized replacement.

2008 Redline Auto
Born 7/20/07
Snagged 8/31/07
Released 8/8/15
Bogie is offline  
post #14 of 20 (permalink) Old 09-07-2008, 10:50 AM
Senior Member
 
xmicro_Redline's Avatar
 
Join Date: Dec 2006
Location: Beautiful Las Vegas, Where everyday is a sunny one
Posts: 5,438
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks Karen!!

OK my 07 Redline, DOES NOT have that problem. I would replace those screws, mucho pronto! Take one out down to a LOCAL Hardware store (if one of yours survived the Home depot onslaught of the 90's), not the crap at Home Depot and get replacements as Bogie said!

They must have either cut a corner second model year, or got a bad batch.... probably from freakin' China!

You can also take them out, steel wool them and paint them!
xmicro_Redline is offline  
post #15 of 20 (permalink) Old 09-07-2008, 12:26 PM Thread Starter
Senior Member
 
SR819's Avatar
 
Join Date: Jul 2008
Location: Colonial Heights Virginia
Posts: 577
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by xmicro_Redline View Post
Thanks Karen!!

OK my 07 Redline, DOES NOT have that problem. I would replace those screws, mucho pronto! Take one out down to a LOCAL Hardware store (if one of yours survived the Home depot onslaught of the 90's), not the crap at Home Depot and get replacements as Bogie said!

They must have either cut a corner second model year, or got a bad batch.... probably from freakin' China!

You can also take them out, steel wool them and paint them!
My 07 did not have this problem either so it is probably just as you said cost cutting measures. THANK YOU KAREN FOR PICKING UP THE SLACK ON THE PHOTOS

Hers--RIP
07' Sunburst2.4l
2-14-07
3 pedals

Mine

08' Carbon Flash SE RL
6-4-08
3 pedals
No Goofy Spoiler
Vin# who cares

http://imsaturn.com/profile/sr819]
SR819 is offline  
Reply

  Saturn Sky Forums: Saturn Sky Forum > Saturn Sky Discussion > General Saturn Sky Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Saturn Sky Forums: Saturn Sky Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome