P0455 and P0497 codes help - Saturn Sky Forums: Saturn Sky Forum
Saturn Sky Redline Discussion Forum for discussion of aspects of the anticipated hi-performance version of the Saturn Sky.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-28-2019, 06:33 PM Thread Starter
BS5
Member
 
Join Date: Sep 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
P0455 and P0497 codes help

I have a 2008 redline,
I believe the P0455 code is evap system leak detected and the P0497 is evap low purge flow.

I tested the purge solenoid under the hood, it was failed open. I replaced with a new one and reset my codes. They popped up again and now I have replaced my gas cap and the evap vent canister (may not be the right name) which was located in the trunk in the gas tank compartment.

I'm really stumped now, cause I'm still getting these codes. I believe these 3 things I have replaced are what I have found recommended on this forum and other sources with these codes.

My cars symptoms are a rough idle, and rarely a hard start. This does not get worse after filling up. I dont notice a gassy smell often at all, only when the car sits for an extended period of time (happened once when I came back from out of town).

Any recommendations from anyone would be greatly appreciated. Thank you!

Last edited by BS5; 05-28-2019 at 06:38 PM.
BS5 is offline  
post #2 of 3 (permalink) Old 05-28-2019, 06:52 PM
Moderator
 
JohnWR's Avatar
 
Join Date: Aug 2006
Location: Lexington, KY
Posts: 4,551
Mentioned: 37 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
There have been reports of cracked hoses, especially at the ends, and you could also have a bad connection due to a stiffened hose.

Is the EVAP Vent Solenoid part of the EVAP Canister? If it is stuck open or leaking it looks like you could get these codes.

You could also have an electrical fault that is keeping one or the other of the valves from functioning, and you could have a problem with the fuel tank pressure sensor.
Electrical problems shouldn't cause any running problems, so you can probably rule them out.

John
Lexington, KY
Sky NA 2007 Midnight Blue
Sky RL 2008 Carbon Flash - Naked
JohnWR is online now  
post #3 of 3 (permalink) Old 05-28-2019, 07:08 PM Thread Starter
BS5
Member
 
Join Date: Sep 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by JohnWR View Post
There have been reports of cracked hoses, especially at the ends, and you could also have a bad connection due to a stiffened hose.

Is the EVAP Vent Solenoid part of the EVAP Canister? If it is stuck open or leaking it looks like you could get these codes.

You could also have an electrical fault that is keeping one or the other of the valves from functioning, and you could have a problem with the fuel tank pressure sensor.
Electrical problems shouldn't cause any running problems, so you can probably rule them out.
The hoses are the next thing on my list then.

I've been trying to find out if the solenoid is part of the canister, and every part I'm seeing is coming up as the part I replaced. That leads me to believe that they are one of the same. Though I'll have to dig some more.

Those last two are possible causes I have not thought of. I'll begin looking into those also.

Thank you for your help, these may help lead me to finding the problem.

I'll post an update if I find anything out.
BS5 is offline  
Reply

  Saturn Sky Forums: Saturn Sky Forum > Saturn Sky Discussion > Saturn Sky Redline Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Saturn Sky Forums: Saturn Sky Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome