Saturn Sky Forums: Saturn Sky Forum - Reply to Topic
Saturn Sky Performance Discussion Internal Engine | External Engine | Suspension | Exhaust | Upgrades and Aftermarket

Thread: Finally The Skpel is running Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now



In order to be able to post messages on the Saturn Sky Forums: Saturn Sky Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-25-2019 10:06 AM
Elff Id get a second opinion
Plenty of Sky owners have installed that.
Its all a matter of doing it properly.
Removal is even trickier. Slow and steady with heat.

The paint on my 4c is very brittle. My sky was much more resistant to chips. I have Clear bra over the entire hood, headlights, mirrors and lower half of the car from just behind the front wheel to just in front of the rear wheel.

Its worked very well
01-24-2019 10:37 PM
skersfan Elf, I assume you are talking about the 3M cover. I know, but I do trust him. He won't put it on any American car. He will do German and Japanese cars, but nothing painted in the US. I have asked him to do it many times. He says it is just not worth the chance.
01-24-2019 07:37 PM
Elff Thats the first and only time I have ever heard that.
01-24-2019 06:37 PM
skersfan My graphics guy absolutely refuses to put it on my car. He says it will pull the paint off. I think our paint here is a little different than other states, not sure on that. He says the new stuff from 3m is so strong it will and has done damage to cars setting over night in his shop. I have known him for 15 years, and he has wrapped my FJ a few times, the green car and the yellow car. Not to mention several friends vehicles.

I had quarters in front of the rear wheels repainted before the national and already have chips in the paint. The side flares actually seems to have made it worse. I am thinking about a 3/8 piece of plywood, covered in epoxy and resin under the car. That sticks out about 2 inches at the front to 3 before the rear wheel. Painted Black or actually made of carbon fiber. These Bridgestones just pick up so much stuff and rocket it into the side of the car it is unbelievable.
01-24-2019 10:49 AM
Elff Just install a clear bra on the doors and in front of the rear wheels.
Replace it as needed but that should protect it for about 3 years.
01-24-2019 10:22 AM
Robotech
Quote:
Originally Posted by skersfan View Post
@Robotech has more time in the passenger seat than anyone with all the tuning that has been going on. He is very agile for a small elephant, but getting in and out of the passenger seat for him is a real chore. lol
You know, we're going to have to renegotiate my peanut allotment if you keep that up. LOL

Quote:
My car seemed quite fast with the base trifecta tune, I really don't feel that much of an improvement to be honest. But it has been a year since I last drove the car the way it was.

A word of warning to others, I think it has been mentioned several times. Do not put the front mud flaps on your car for any reason. The one we just bought had them all the way around. Today looking at the fenders off the car, both are broken under the Mud Flaps, and the mud flaps are broken, when they hit something it appears they put like a teeter totter affect in them. Holes are nearly perfect to the mudflap. Not done by a lift. I took some pictures but will post later in a post just regarding these things.
I think your car is quicker now. By a considerable amount. It was quick before, but it seems quicker with the new setup.

As for the mud flaps, that's something we learned back in 2006 and why you don't see them on my car. I'd love to have something to prevent rocks from flying up and blasting my quarter panels behind the doors but unless I finally get around to making side extensions for this thing it is what it is.
01-24-2019 09:18 AM
Rob the Elder Or



01-24-2019 07:33 AM
JohnWR I have the emulator, and have been using it for the last several months, so I won't be completely out of luck, but I would like to have the real thing.
01-24-2019 12:33 AM
skersfan I thought I had read on this site, that they were out of them a few weeks back. Maybe not. Hope they aren't out and you get yours. It appears I have two working ones in the Two NA's I have. Will rob one of those if all else fails.
01-23-2019 10:46 PM
JohnWR If you have a Service Airbag notification on the DIC you do probably have a bad sensor. Does GM have any more? I hope so, since I am going to need two.
01-23-2019 08:38 PM
skersfan It is on the DIC, service air bag or something like that. The seat indicator does not indicate someone is in the seat. My guess is the cushion was ready to fail, the tape was applyied last summer. @Robotech has more time in the passenger seat than anyone with all the tuning that has been going on. He is very agile for a small elephant, but getting in and out of the passenger seat for him is a real chore. lol

Bill I think it is that the cushion has failed. It worked fine until we started this night mare.

I have another code, but I think it has to do with light bar. We will figure that out after I get the engine light out.

My car seemed quite fast with the base trifecta tune, I really don't feel that much of an improvement to be honest. But it has been a year since I last drove the car the way it was.

A word of warning to others, I think it has been mentioned several times. Do not put the front mud flaps on your car for any reason. The one we just bought had them all the way around. Today looking at the fenders off the car, both are broken under the Mud Flaps, and the mud flaps are broken, when they hit something it appears they put like a teeter totter affect in them. Holes are nearly perfect to the mudflap. Not done by a lift. I took some pictures but will post later in a post just regarding these things.
01-23-2019 06:43 PM
JohnWR The indicator gets power and control from three different places, so which lights work and which don't can tell you a lot about what is wrong.
01-23-2019 05:32 PM
44thSKY skersfan, just saying ...... I think it was JohnWR that detailed how to get the cover off the airbag status light and check the connection. That was a couple years back when I did that.

I found the wire was NOT plugged into the lamp, just laying there doing nothing. Plugged it in and the airbag status was as expected and never failed to work thereafter.

Have no idea why it was that way, but that was the way it was when I bought the car in 2011.
01-23-2019 03:49 PM
Robotech
Quote:
Originally Posted by skersfan View Post

Now the car seems to run fine, still fuel residue on the back of it. Only one code and Robo seems to think it can befixed with the next tune from Dave.
Dave says the code is because your three bar MAP isn't quite up to reading the 29-30 psi you're making KR free (a three bar should read up to 29.4 psi but if you're right there it may throw this code). Scan he said looks good. He sent me another tune that's going to lower the boost a bit and see if that doesn't clear up the P0103 code.

Fuel residue is going to be from the richer mixture that is providing this kind of power.
01-23-2019 02:45 PM
JohnWR
Quote:
Originally Posted by skersfan View Post
.........Passenger air bag light is not working, and the car has had the upgrade. Once I get the check engine light out, I will take it by the dealership and have them do what can be done. I don't think they have any more cushions.
What is the symptom of the light not working?
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome