Saturn Sky Forums: Saturn Sky Forum - Reply to Topic
General Saturn Sky Discussion Forum for discussing general topics on the Saturn SKY.

Thread: automatic door lock/ unlock solinoid replacement Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now



In order to be able to post messages on the Saturn Sky Forums: Saturn Sky Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-18-2019 01:01 PM
TomatoSoup
Quote:
Originally Posted by tporter View Post
yes both doors and buttons. but most of the time they pop when I go into park, have more power to the pop
Ahhh, so both do the same thing, but work OK in certain circumstances. This is sounding more like an electrical (low power) problem. I would say bad battery, but more things are likely to be going wrong in that case. Maybe a bad wire/connector somewhere?
06-18-2019 12:59 PM
JohnWR There is no difference between using the fob and shifting to park, except that the engine is not running when you are using the fob, so the voltage powering them is less.
I would try pulling the fuse and the relay (if it is removable) and putting them back in, maybe two or three times. There could be some corrosion on the terminals reducing the voltage available.
06-18-2019 11:28 AM
tporter yes both doors and buttons. but most of the time they pop when I go into park, have more power to the pop
06-18-2019 11:23 AM
TomatoSoup
Quote:
Originally Posted by tporter View Post
I opened up the door and lubed the unit.. it doesn't quit working, it just works at lower power. this is a new fob too. I have 3 programmed and it functions the same way with all three. if I wait a few mins and try it again, it goes through the same progression. sometimes it have to unlock, then use my key in the door to pop the lock up. then 10 mins later it will pop with the fob.
Again... same on both doors or just one? Same with door buttons or not?
06-18-2019 11:04 AM
tporter I opened up the door and lubed the unit.. it doesn't quit working, it just works at lower power. this is a new fob too. I have 3 programmed and it functions the same way with all three. if I wait a few mins and try it again, it goes through the same progression. sometimes it have to unlock, then use my key in the door to pop the lock up. then 10 mins later it will pop with the fob.
06-18-2019 11:03 AM
TomatoSoup Ahh, OK, that does sound like the solenoid then, but is this the same with both doors? Seems unlikely that both solenoids would fail at the same time.

Again, do the door lock buttons exhibit the same issue?

Meanwhile, the lock/solenoid is part #3 below. See: https://www.cultragfactoryparts.com/...-cat/door-scat and scroll down to bottom half to see part #s & prices

06-18-2019 10:57 AM
JohnWR It could be a lube issue in the lock mechanism.
06-18-2019 10:53 AM
tporter fobs were programmed to work with the car, I was told weak battery in fob originally, then replaced with a brand new fob. the fob works fine. if I press more than once, the locks start losing steam. it reacts to the press, but with less "umph" each time. if that makes sense.
06-18-2019 10:43 AM
TomatoSoup Do the door lock switches work? If so, it's not the solenoids.

When you say "replaced with new ones", what exactly was replaced? If you replaced the whole fob, then it needs to be reprogrammed with a TechII (or similar) before it will work at all.

The door lock solenoids are part of the whole catch/lock assembly, so if it proves to be the solenoid at fault, you'll have to replace that whole piece.
06-18-2019 09:39 AM
tporter
automatic door lock/ unlock solinoid replacement

Been Having an issue with my door locks not unlocking with keyfob. replaced with new ones, still have issue. does anyone know where I can get a new solenoid, or any part #'s or instruction on how to replace. TIA

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome