Saturn Sky Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Took the Sky for a ride this afternoon. Stopped at a friend's house and upon leaving the Sky had almost no power. Light in dash showed engine outline and message read something like "eng pwr reduced". Motor sounded OK but it had very little power and I basically had to shift motor to L then up to I then to 4 etc. to get it to move down the road. It would slowly rev to 4000 then I'd shift to next gear and all the while with very little power. Any ideas as to the problem? Motor has 26,000 miles and never had any problems before..
 

·
Super Moderator
Joined
·
11,347 Posts
Could be a problem with the solenoid or a leak somewhere in your system. Something like this usually means you have had a coupler come off a pipe somewhere. Check all your couplers to make sure they are on and the clamps tight.
 

·
Super Moderator
Joined
·
6,117 Posts
Could be a problem with the solenoid or a leak somewhere in your system. Something like this usually means you have had a coupler come off a pipe somewhere. Check all your couplers to make sure they are on and the clamps tight.
Second that. Also get the codes read. That will likely point you closer to the problem.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I finally got the code read on my "reduced horse power" message. It said bad fuel pump. It turned out to be the high pressure mechanical pump mounted to engine. Found them on E-bay from $85.95 to over $ 300.00 ! Has anyone had experience with the low cost pumps? They have a 1 year warranty same as expensive ones. They're not that hard to get to too change so I went with the less costly one, after all the Bosch pump only lasted 26,000 miles.
 

·
Super Moderator
Joined
·
6,117 Posts
Glad that you got it figured out.
 
1 - 5 of 5 Posts
Top