Saturn Sky Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Had a transmission shop tell me there's an internal low band malfunction with the transmission.

Anyone have any experience with this?

Thanks
 

·
Registered
Joined
·
854 Posts
Current mileage @ 127k still? Has the fluid ever been replaced, over 100k factory recommended? Any problems that you were having before this inspection by the shop, why did you go there in the first place? Noises or sounds, bucking during low speed torque? Highway speed hum or shifting by itself?
Grinding of the gears, slow to shift or something other than that?

There are a few owners here that have had their transmission repaired/replaced. Has this problem that the shop has told you ever worked on your car before or the Kappa in general?

Could it be the cam position sensors, intake/exhaust that have been known to cause, the hard shift, 1st to 2nd or downshift in our models before?
2nd opinion from a different shop? Low band malfunction.... is this just recent, or something that was evident when you purchased the car but were unable to correct, just assumed it was like that from the factory?

You'll get an answer from someone here on the forums.

LAC
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
Thank you LAC, sorry I had not seen that anyone had answered the post until now. Current mileage is at 129k, and fluid was changed at 100k. Being this was my first experience with a Sky, I assumed it was shifting correctly. Plus it had been to the dealer a few times recently so I would have thought they would have noticed something.

The car wouldn’t shift out of 2nd gear even when trying to manually shift through the gears. The check engine light came on that’s when it was checked by a local tranny shop. The shop is owned by a personal friend so I don’t think they are scammers. I guess you never know.

Anyway, I found a used tranny for $750, going to go that route. They wanted $2000 to rebuild it.

Transmission place said the transmission parts inside were all from BMW, is that correct?

Thanks again for your response, truly appreciate it.

Have a good rest of the long weekend!

D


Current mileage @ 127k still? Has the fluid ever been replaced, over 100k factory recommended? Any problems that you were having before this inspection by the shop, why did you go there in the first place? Noises or sounds, bucking during low speed torque? Highway speed hum or shifting by itself?
Grinding of the gears, slow to shift or something other than that?

There are a few owners here that have had their transmission repaired/replaced. Has this problem that the shop has told you ever worked on your car before or the Kappa in general?

Could it be the cam position sensors, intake/exhaust that have been known to cause, the hard shift, 1st to 2nd or downshift in our models before?
2nd opinion from a different shop? Low band malfunction.... is this just recent, or something that was evident when you purchased the car but were unable to correct, just assumed it was like that from the factory?

You'll get an answer from someone here on the forums.

LAC





Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
51 Posts
Had a transmission shop tell me there's an internal low band malfunction with the transmission.

Anyone have any experience with this?

Thanks
Give Apex Automotive in Delray Beach a call first...The owner knows Kappas....the shop is on Linton Blvd.
 
1 - 5 of 5 Posts
Top