Saturn Sky Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So to make things simple. I have a practically bone stock 2007 Saturn Sky 2.4L with deleted resonators and mufflers. Other than that it just has minimal rigged up qualities to keep it going. With that being said here's where my issue...

I'm losing power and the only thing I didn't see anyone talk about was the antitheft system! I have been dealing with this for quite some time and just got a key programmed and made for my ignition cylinder last night. I think my issue may be a faulty battery and fried starter. I know my starter is fried, but the alternator and battery are supposedly brand new. I push started my car last night and drove it some 30 miles or so and was having similar power lossage issues but nothing major yet. It wasn't until after I got to my location and turned off my sky and had someone push start it with me again did I see the ABS light come on mind you my starter is still fried. it started having the antitheft light come on after I got to my third location and this is happening because my key broke a while ago. And my battery was dying and my starter was going out but I didn't know till it was too late and so here I am today. with a possible faulty battery that I just purchased, (still has warranty) a brand new starter sitting on my dining table, and a brand new alternator already in the car. We used jumper cables to get the car back to full power had to leave the cables on it for 5-10 minutes to let it charge some. after removing the cables the car would die out again without turning it on even with the new key in the ignition in the run position engine off. we got a full charge and push started the vehicle as fast as possible motor turned over, alternator turned over, (remanufactured from autozone) car started and the antitheft system was off no light showing for a solid 30 seconds and then i turned on the a/c and the car turned off within the next 15-20 secs and the anti theft light was back on.... and I lost all power of course anyone please help!
 

·
Registered
Joined
·
1,689 Posts
Being clear here....I offer no solution, only wondering what the ramifications of push-starting a high-technology car. A Sky is not a 60's vintage car that is easily hot-wired. You mentioned the security system as a possible factor and I wonder too. I also would be concerned of damaging electronics.
 

·
Administrator
Joined
·
7,327 Posts
So to make things simple. I have a practically bone stock 2007 Saturn Sky 2.4L with deleted resonators and mufflers. Other than that it just has minimal rigged up qualities to keep it going. With that being said here's where my issue...

I'm losing power and the only thing I didn't see anyone talk about was the antitheft system! I have been dealing with this for quite some time and just got a key programmed and made for my ignition cylinder last night. I think my issue may be a faulty battery and fried starter. I know my starter is fried, but the alternator and battery are supposedly brand new. I push started my car last night and drove it some 30 miles or so and was having similar power lossage issues but nothing major yet. It wasn't until after I got to my location and turned off my sky and had someone push start it with me again did I see the ABS light come on mind you my starter is still fried. it started having the antitheft light come on after I got to my third location and this is happening because my key broke a while ago. And my battery was dying and my starter was going out but I didn't know till it was too late and so here I am today. with a possible faulty battery that I just purchased, (still has warranty) a brand new starter sitting on my dining table, and a brand new alternator already in the car. We used jumper cables to get the car back to full power had to leave the cables on it for 5-10 minutes to let it charge some. after removing the cables the car would die out again without turning it on even with the new key in the ignition in the run position engine off. we got a full charge and push started the vehicle as fast as possible motor turned over, alternator turned over, (remanufactured from autozone) car started and the antitheft system was off no light showing for a solid 30 seconds and then i turned on the a/c and the car turned off within the next 15-20 secs and the anti theft light was back on.... and I lost all power of course anyone please help!
Hi Suazi,

I deleted your other post about this because it is better to keep this to one thread.

What "rigged up qualities" do you have? They could be significant.

Your battery and/or alternator seem to be bad, and you should get both tested to see which it is.

After that I would replace the starter to make everything else easier.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Being clear here....I offer no solution, only wondering what the ramifications of push-starting a high-technology car. A Sky is not a 60's vintage car that is easily hot-wired. You mentioned the security system as a possible factor and I wonder too. I also would be concerned of damaging electronics.
Well everything is a concern but the main concern is I must fix must my car....
 
1 - 4 of 4 Posts
Top