Saturn Sky Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Been Having an issue with my door locks not unlocking with keyfob. replaced with new ones, still have issue. does anyone know where I can get a new solenoid, or any part #'s or instruction on how to replace. TIA
 

·
Registered
Joined
·
4,072 Posts
Do the door lock switches work? If so, it's not the solenoids.

When you say "replaced with new ones", what exactly was replaced? If you replaced the whole fob, then it needs to be reprogrammed with a TechII (or similar) before it will work at all.

The door lock solenoids are part of the whole catch/lock assembly, so if it proves to be the solenoid at fault, you'll have to replace that whole piece.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #3
fobs were programmed to work with the car, I was told weak battery in fob originally, then replaced with a brand new fob. the fob works fine. if I press more than once, the locks start losing steam. it reacts to the press, but with less "umph" each time. if that makes sense.
 

·
Super Moderator
Joined
·
5,902 Posts
It could be a lube issue in the lock mechanism.
 

·
Registered
Joined
·
4,072 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #6
I opened up the door and lubed the unit.. it doesn't quit working, it just works at lower power. this is a new fob too. I have 3 programmed and it functions the same way with all three. if I wait a few mins and try it again, it goes through the same progression. sometimes it have to unlock, then use my key in the door to pop the lock up. then 10 mins later it will pop with the fob.
 

·
Registered
Joined
·
4,072 Posts
I opened up the door and lubed the unit.. it doesn't quit working, it just works at lower power. this is a new fob too. I have 3 programmed and it functions the same way with all three. if I wait a few mins and try it again, it goes through the same progression. sometimes it have to unlock, then use my key in the door to pop the lock up. then 10 mins later it will pop with the fob.
Again... same on both doors or just one? Same with door buttons or not?
 

·
Registered
Joined
·
76 Posts
Discussion Starter #8
yes both doors and buttons. but most of the time they pop when I go into park, have more power to the pop
 

·
Super Moderator
Joined
·
5,902 Posts
There is no difference between using the fob and shifting to park, except that the engine is not running when you are using the fob, so the voltage powering them is less.
I would try pulling the fuse and the relay (if it is removable) and putting them back in, maybe two or three times. There could be some corrosion on the terminals reducing the voltage available.
 

·
Registered
Joined
·
4,072 Posts
yes both doors and buttons. but most of the time they pop when I go into park, have more power to the pop
Ahhh, so both do the same thing, but work OK in certain circumstances. This is sounding more like an electrical (low power) problem. I would say bad battery, but more things are likely to be going wrong in that case. Maybe a bad wire/connector somewhere?
 
1 - 12 of 12 Posts
Top