Saturn Sky Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter #1
Has anyone encountered the problem when the top is down and the silver buttress cover sticks open a little bit? Here are some pictures of what I'm currently experiencing. Notice the passenger side is worse, but the driver's side is getting that way also...

Passenger Side:
100_1663.jpg 100_1665.jpg 100_1666.jpg

Driver's Side:
100_1664.jpg 100_1667.jpg
 

·
Moderator Emeritus
Joined
·
2,238 Posts
I'd take that puppy into the dealer.:lol:
 

·
Registered
Joined
·
1,547 Posts
Definitely take it in for service. Probably just need some adjustment on the cable that controls the panel.
 

·
Registered
Joined
·
4,876 Posts
Yes looks like an adjustment is needed -- take it in....:D
 

·
Registered
Joined
·
154 Posts
SkyPup said:
Has anyone encountered the problem when the top is down and the silver buttress cover sticks open a little bit? Here are some pictures of what I'm currently experiencing. Notice the passenger side is worse, but the driver's side is getting that way also...

I do have a slight problem exactly like that on mine also, I am sure it is just a minor adjustment. I will have them take crae of it when I take it in for its first oil change (soon).
 

·
Registered
Joined
·
41 Posts
same problem

I have had the same thing, since day 1, on my right side. Driver side has never been a problem. Somebody tell the guy on the right side of the line to give us a bit more slack...

I am waiting until my replacement backup light (got foggy on me) comes in and will take it in for a fix on both issues.
jonm
 
1 - 7 of 7 Posts
Top