Saturn Sky Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Shop put in aftermarket fan 8 months ago. Took back cause fan stopped working. They replaced with new OEM fan from dealership and same problem. They tested both fans outside of the car and both aftermarket and OEM fans work, but once connected to the car neither do. They're saying might be the ECM or BCM and will have to take the car to the dealership since it will need reprogramming. Any ideas? 08 Redline manual
 

·
Administrator
Joined
·
8,247 Posts
Shop put in aftermarket fan 8 months ago. Took back cause fan stopped working. They replaced with new OEM fan from dealership and same problem. They tested both fans outside of the car and both aftermarket and OEM fans work, but once connected to the car neither do. They're saying might be the ECM or BCM and will have to take the car to the dealership since it will need reprogramming. Any ideas? 08 Redline manual
What did they replace? Just the fan, or the fan and controller?

Did they check for a blown fuse?
 

·
Registered
Joined
·
42 Posts
Is it pro
Shop put in aftermarket fan 8 months ago. Took back cause fan stopped working. They replaced with new OEM fan from dealership and same problem. They tested both fans outside of the car and both aftermarket and OEM fans work, but once connected to the car neither do. They're saying might be the ECM or BCM and will have to take the car to the dealership since it will need reprogramming. Any ideas? 08 Redline manual
Check to see if grounded properly.
 
1 - 8 of 8 Posts
Top