Saturn Sky Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
311 Posts
Discussion Starter · #1 · (Edited)
Disaster struck yesterday, when I had my dealer looking into the prior reported rear wheel rub problem, on my Sky. They found that I was indeed having that very same problem and will fix same. The other problem occured when the service tech was backing the car off the lift. The mud flap caught on the lift and cracked the quarter panel. I was sick! I knew he felt really bad about it but I only had 184 miles on the car for crying out loud!

So, for all you Sky owners out there, remember to remind the servicing people about proper placement of the Sky on the lifts and to remind them of the low clearence on the Sky.:banghead:

Vin# 100814
 

Attachments

·
Registered
Joined
·
420 Posts
ouch! I would have been :mad: as heck if that ever happened to mine.
I'd probably punch a hole in the dealership wall or something, hehehe

regarding the tire rub, what's your VIN number?
I heard they fixed the problem on higher numbers
 

·
Registered
Joined
·
133 Posts
Can you provide a picture of the crack?
 

·
Moderator Emeritus
Joined
·
2,238 Posts
This problem has been seen before. NCBLUE was the first to report getting a Sky and the first to experience the problem if I remember correctly.
 

·
Registered
Joined
·
311 Posts
Discussion Starter · #7 ·
rick112 said:
This problem has been seen before. NCBLUE was the first to report getting a Sky and the first to experience the problem if I remember correctly.

This was a different problem! Got on the lift and up OK. The problem occured while backing off the lift and the mud flap caught on the lift. This caused the panel to crack.
 
1 - 7 of 7 Posts
Top