Saturn Sky Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
2007 sky temp only blows cold air won't change both heater hoses hot mode control won't change blows out ac vents blower works fine ac clutch kicks in and out with button
 

·
Registered
Joined
·
2,189 Posts
Actuator Recalibration
When replacing an air temperature, mode, recirculation actuator or the HVAC control assembly, the following calibration process needs to be performed:

Important: Do not adjust any controls on the HVAC control assembly during self-calibration. If interrupted, improper HVAC performance will result.

1) Turn ON the ignition with the engine OFF.

2) Turn the Temperature dial all the way to the right.

3) Turn the blower control dial all the way to the right.

4) Turn the mode position dial all the way to the left.

5) Simultaneously press and hold the A/C and Defrost buttons until the LED's start to flash.

6) Once the LED's stop flashing, calibration is complete.
 

·
Registered
Joined
·
2,189 Posts
I noticed that when connecting my battery after it has been disconnected for an extended period of time, the 3-pod climate control orange indicator lights flash randomly. Maybe it is trying to recalibrate but the 3 dials are not positioned properly for success. I wonder if recalibration is necessary after connecting your battery.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #8 ·
Actuator Recalibration
When replacing an air temperature, mode, recirculation actuator or the HVAC control assembly, the following calibration process needs to be performed:

Important: Do not adjust any controls on the HVAC control assembly during self-calibration. If interrupted, improper HVAC performance will result.

1) Turn ON the ignition with the engine OFF.

2) Turn the Temperature dial all the way to the right.

3) Turn the blower control dial all the way to the right.

4) Turn the mode position dial all the way to the left.

5) Simultaneously press and hold the A/C and Defrost buttons until the LED's start to flash.

6) Once the LED's stop flashing, calibration is complete.
Tried that several times no luck this did happen after replacing battery i wonder if i disconnected battery for short period and try recalibrating again after battery reconnected
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #9 ·
Tried that several times no luck this did happen after replacing battery i wonder if i disconnected battery for short period and try recalibrating again after battery reconnected
Question when recalibrating and ignition on and engine off and the blower knob to right is blower blowing thats high speed on mine
 

·
Registered
Joined
·
7 Posts
I have a 2007 Saturn Sky and at some point between flipping between the AC and heat the heat stopped working. I have air still blowing but only regular air and AC. No heat at all. I had a mechanic change the actuator but it did not solve the issue. I did the recalibration multiple times also. I would love to see every heat issue addressed in one write up because it seems like it comes up. Any possible solutions for my dilemma anyone?
 

·
Registered
Joined
·
1,159 Posts
The recalibration should have fixed this-
The fact it didn't is puzzling-
Replaced actuator-
Heater hoses are hot
No fuses are blown-
No temp changes-
Battery replaced semi recently-

I just had my battery replaced last year- I too was worried
if a reset to my controls were in order after disconnection
of power- however no problem from the dealer
as I did have A/C this summer- I did have heat/defrost mode in
that rainy drive home from the beach 3 weeks ago.

A collection- with links to past issues with our car is tough
to do- same problem known or not... each of our cars react
differently in some case, what works for owner car A may
not work for owner of car B. I know we have the same model
but... on any given day.

LAC
 

·
Registered
Joined
·
7 Posts
The recalibration should have fixed this-
The fact it didn't is puzzling-
Replaced actuator-
Heater hoses are hot
No fuses are blown-
No temp changes-
Battery replaced semi recently-

I just had my battery replaced last year- I too was worried
if a reset to my controls were in order after disconnection
of power- however no problem from the dealer
as I did have A/C this summer- I did have heat/defrost mode in
that rainy drive home from the beach 3 weeks ago.

A collection- with links to past issues with our car is tough
to do- same problem known or not... each of our cars react
differently in some case, what works for owner car A may
not work for owner of car B. I know we have the same model
but... on any given day.

LAC
Its frustrating and I'm worried about spending thousands trying to experiment. The actuator was replaced and both hoses were hot and the engine temperature is fine. I have not checked the fuses but which one would be affected? I have noticed the low coolant message pop up hear and there but I check and everything is fine. I even did a bleed and the coolant fluid was spitting out. It cant be blockage or the heater core because the engine temp runs normal. The car has 49,000 miles on it.
 

·
Administrator
Joined
·
8,249 Posts
Its frustrating and I'm worried about spending thousands trying to experiment. The actuator was replaced and both hoses were hot and the engine temperature is fine. I have not checked the fuses but which one would be affected? I have noticed the low coolant message pop up hear and there but I check and everything is fine. I even did a bleed and the coolant fluid was spitting out. It cant be blockage or the heater core because the engine temp runs normal. The car has 49,000 miles on it.
If both heater hoses are hot, there is hot water flowing through the core. If you then do not have heater function, the problem is the blend door, its actuator, or the system calibration. As you shift the temperature conrol from cold to hot and back you should hear the actuator operate.
 

·
Registered
Joined
·
2,189 Posts
If the heater hoses are hot, both actuators are replaced & calibrated, then I would lean toward a problem with the 3-pod HVAC unit.
 

·
Registered
Joined
·
7 Posts
If both heater hoses are hot, there is hot water flowing through the core. If you then do not have heater function, the problem is the blend door, its actuator, or the system calibration. As you shift the temperature control from cold to hot and back you should hear the actuator operate.
The actuator was replaced and calibration has been done several times. The mechanic states it worked for a short time and then stopped. He was frustrated and even unsure because he has never worked on a Saturn Sky. It seems to be something between the controller and actuator?
 
1 - 20 of 29 Posts
Top