Saturn Sky Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter #1
How much boost should I be getting in 5th gear doing 85-100 mph? I can't seem to get over 14-15 psi max in 5th.
Is that normal?

(I did not check it in 4th)
 

·
Registered
Joined
·
40 Posts
If your stock that seems right, car only produces enough boost to give you 260 tq regardless of gear
 

·
Registered
Joined
·
191 Posts
Discussion Starter #3
Thanks, I never seemed to get above 14-15 psi for a few seconds of acceleration. Good to know that is fine for a stock car.
 

·
Registered
Joined
·
434 Posts
Boost has nothing to do with your tune. As I learned quickly here. You could be tuned and only see 14-15psi. You could not be tuned and see 18psi. It depends. There are several other ways to tell....

Do you only have 1 screw holding your MAP sensors down? If there are 2 screws, you have the OE factory MAP sensors.

The only other way I know of is getting a true OBDII diag program from a GM engineer and seeing what 4 "part numbers" make up your tune. There are 4 parts to the ECM tune and each one has a unique "part number" associated with it. This is the way I found out my car was initially tuned.
 

·
Registered
Joined
·
191 Posts
Discussion Starter #5
I should have mentioned this before, I am stock, no tune… yet.
 

·
Premium Member
Joined
·
4,190 Posts
The boost level is set on the fly by the ECM to produce the target 260 ft pounds of torque as was mentioned above.

The MAF sensor provides data that is used to determine the temperature of the incoming air. It also provides data that is used to calculate the relative air pressure. The tune changes the boost level to match the temperature, humidity and air density. At sea level, its normal to see 12-15 pounds of boost indicated. At 5000 feet that same performance level may result from 15-17 pounds of boost. The same car, driven on a hot day may produce 17 pounds of boost and on a cold day, on the same road only produce 15 pounds of boost.

Here is some reading

https://www.solsticeforum.com/forum/f63/gm-stage-ii-kit-review-52407/
 

·
Registered
Joined
·
4 Posts
Same Boost

Mine is the same. Getting 14 psi at about 65 and then it drops off. Going to do upgrade over the holidays. Having the Chevrolet dealer remap after the sensor change because 07s have a special security issue the newer models don't have installed. That's what mech told me.
 
1 - 7 of 7 Posts
Top