Saturn Sky Forum banner

41 - 60 of 73 Posts

·
Registered
Joined
·
209 Posts
I guess they used a different ECM than was listed for the corvette write up I saw. Back to thinking either the sky’s use a different input pin or hp tuners has missed something in their protocols.
 

·
Registered
Joined
·
5 Posts
I have triple checked continuity at that pin. I did find that the c7 corvettes that use a e67 ecm use pin 38. The sky pinout shows that pin is open. I may try that today.
EDIT: Missed that you had figured this out already, but I'll leave this information here in case it's useful to anyone else.

The C7 Corvette and other Gen 5 V8s use a different ECM, E92:

The C6 Corvette and other Gen 4 V8s use the E67, and all the documentation I can find for that matches what you already have--C1, pin 5.

So, hopefully that saves you from wasting time trying the wrong thing. Unfortunately I don't have any other ideas.
 

·
Super Moderator
Joined
·
11,292 Posts
Discussion Starter #44
Nice to see this. Will be interesting to see what you find out...this damn pandemic is really making it damn near impossible to get my oil leak resolved.
 

·
Registered
Joined
·
209 Posts
Robotech, do you have a flex fuel sensor you can try to rig up and log with the beta os? Mine is not working and they say it should. I want to eliminate all variables.
 

·
Registered
Joined
·
209 Posts
If you have the sensor, you just need to hook it to power, ground and the signal pin goes to C1 pin 5. With the key on run and the sensor not hooked up to the fuel line it should read 50hz for 0% The pid for this valve on the beta scanner is just called flex fuel. There is also a fuel content ratio and frequency PID if you could try those too that would be super helpful.
 

·
Registered
Joined
·
4 Posts
Figured I'd join the conversation, Robotech mentioned me early in the thread. Got my sensor hooked up to c1 pin5 and I don't get a signal. Also, somewhere in the beta you can turn on flex fuel diagnostics and I did that. The code I get is flex fuel sensor circuit low input. On the scanner I didn't get any values for the flex fuel sensor. I have considered going to the e37 out of a ffv hhr but if hptuners can get this figured out it'd save me work and money lol.
 

Attachments

·
Super Moderator
Joined
·
11,292 Posts
Discussion Starter #51
Well, hooked it up, turned some things on, and my computer died before I could figure out how to read the voltage from the sensor. Charging laptop and will try again.
 

·
Super Moderator
Joined
·
11,292 Posts
Discussion Starter #53
Yea, I figured it out.

What got me twisted was the Flex Fuel percentage was under Engine > Fuel > Flex Fuel and the comp ratio and freq was under Fuel System > Composition.
 

·
Super Moderator
Joined
·
11,292 Posts
Discussion Starter #55
Well, 0 hrz from the sensor in HPT but I went to check for power and ground at the plug and couldn't get a reading. Not sure if it is how I have it wired (off the O2 power and ground), a break somewhere or just couldn't get good contact in the plug (or even a bad meter...been a while since I used it) so I wouldn't call it concrete. I have bigger issues on it right now so I don't want to go down that rabbit hole at the moment.
 

·
Registered
Joined
·
209 Posts
If you’re running it off the O2 sensor circuit, it may be for the heating circuit which would turn off after so long of time.
 
41 - 60 of 73 Posts
Top