Saturn Sky Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
Just bought a 2007 Base model Sky, and in love with it! only 48,000 miles and I am ready to ride her all summer long. However, besides having the engine light come on, due to putting the cheap gas in it, I will start using the higher octane. My concern is, is that the heat is not there and it only blows out cool air. The temp from the radiator is at 185-192, so I don't think it has anything to do with that. Please help me out

Luke
 

·
First 2000 Sr. Member
Joined
·
1,875 Posts
you posted in a TEST forum. its been a while so I am sure you've solved by now
 

·
Premium Member
Joined
·
4,151 Posts
Remember, do not leave the fan controller on HIGH for long periods of time. It can overheat the motor control resister and cause failure.

Welcome to the forum
 

·
Registered
Joined
·
90 Posts
actually ever since i purchased my car i first filled on premium just once for a nice long drive and ever since just the cheapest stuff saves me 20 cents and i get a gallon more or so
 

·
Registered
Joined
·
854 Posts
Try the HVAC recalibration to your controls see if that helps with the heat problem. Low temps reading is good, normal range for the Kappa. IF it gets to 230 reading, not so good.

If you still have no heat after the recalibration is done, you could have other problems with it, the heater core that might have to be checked out?

With the base model 2.4 you should be able to run 87/89 octane with no problems. A tank full of 91 once in awhile is not a bad thing, if it is not too expensive for you? Good to save money now, just in case something goes wrong later. Kappa is not the cheapest thing out there to repair, on occasion that something major goes wrong with it. I would find out what service has been done to it, by the previous owner/dealer, as a base line history for future maintenance reference through a GM dealer by your vin#.

Enjoy the ride and the premagrin.

LAC
 
1 - 8 of 8 Posts
Top