Saturn Sky Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter #1
So yesterday my top latch on my passenger side(the part you press down into the buttress) got stuck. It didnt lift out automatically when the remote was used to open the trunk. pressing the trunk back down it released and i could get in no problem. But them closing it was a huge ordeal, it seems to be scraping.
Upon looking at it i realize that where my driver side is pretty much coming down center over the hole in the buttress, my passenger side is way off center (landing much further back toward the main part of the top. Like its not stretching out far enough).

Obviously this is something to do with alignment, but its odd to just happen so suddenly. Any suggestions? Some way to actually adjust this that i dont know of? Any help is appreciated. I constantly have my top going up and down(I live in southeast missouri, all seasons in a 24 hours period) so this is more than a slight annoyance.
 

·
Registered
Joined
·
391 Posts
I have the same issue on my passenger side. I adjusted the large pin to align to the hole using Hoosier GXP's method using a 15mm deep socket and extension as a handle, but the pin is now at an angle rather than being perpendicular to the hole which causes an occasional hang-up when releasing. I want to grab the end and stretch the buttress rearward, but of coarse nothing gives.
 

·
Registered
Joined
·
271 Posts
Discussion Starter #3
I have the same issue on my passenger side. I adjusted the large pin to align to the hole using Hoosier GXP's method using a 13mm deep socket and extension as a handle, but the pin is now at an angle rather than being perpendicular to the hole which causes an occasional hang-up when releasing. I want to grab the end and stretch the buttress rearward, but of coarse nothing gives.
Stretching it is exactly what i want to do. lol. Just not sure why it happened so suddenly like that. Its not a little off, its quite a bit.
Ill see if i can find the method that youre talking about. Sounds like it might fix my allignment issue at least a little.
 

·
Registered
Joined
·
391 Posts
Hey Draike13, Tonight I resolved my flip-up buttress problem.

Earlier in the year, I had removed the decorative chrome finishing washers on the trunk lid to remove both of my clear films that cracked and darkened from the sun. Tonight I noticed on the problem buttress, I adhered the chrome trim washer ever-so slightly off in a direction that amplified my clearance problem. I removed the decorative chrome finishing washer and operated the flip-up buttress with no trouble at all. So I replaced the adhesive and reattached the washer to favor the clearance requirement, only as much as it could tolerate before it started to look odd.

If you wonder, I used this automotive grade 3M tape sold at many auto parts stores. It works exceptionally well. I removed the washer using fishing line.
112871
 
1 - 4 of 4 Posts
Top