Saturn Sky Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter #1
I was wondering if anyone else has come across this problem. Yesterday my display on my stereo went completely blank. After a while it came back and then went off again. I have the 6 disk CD player and even though the screen was blank everything else worked perfectly including the steering wheel controls. If it is an intermittent problem something could be loose but my concern is that I'll have a problem duplicating the problem to show the dealerships maintenance department and I don't want them to say they'll keep the car a few days and use it to see what happens. If anyone has run across this problem and know a fix please let me know.
Thanks,
Jayne
 

·
Registered
Joined
·
1,205 Posts
Jayne said:
I was wondering if anyone else has come across this problem. Yesterday my display on my stereo went completely blank. After a while it came back and then went off again. I have the 6 disk CD player and even though the screen was blank everything else worked perfectly including the steering wheel controls. If it is an intermittent problem something could be loose but my concern is that I'll have a problem duplicating the problem to show the dealerships maintenance department and I don't want them to say they'll keep the car a few days and use it to see what happens. If anyone has run across this problem and know a fix please let me know.
Thanks,
Jayne
No Jayne, your not alone. I have the 6 disc too. Mine did the exact same thing when I picked her up Friday. Went from no sound to sound with a blank screen. They will be re-installing a new one this week when I drop her off for the dealer extras I purchased. Now it is working fine, but I'm still going to have it replaced. Good luck to ya...:thumbs:
 

·
Registered
Joined
·
129 Posts
Discussion Starter #3
5/12/06

I also took delivery of my Baby on the 12th. Could be a bad day for radio problems but one great day because we finally got into the drivers set. I'll see if the problem continues and then request that the radio be changed out. The on-star is great. I'm still in the learning process here. There are so many new and wonderful things to learn but time is really a problem...too busy driving :) Hope you are enjoying your Sky as much as I am. I wish I knew how to post pictures because I already gave my baby a pink heart, fairy decals and her name on the back of the windscreen "Corievette". Thanks for letting me know I was not alone.
Jayne
 

·
Registered
Joined
·
337 Posts
Very Interesting

I use to have a GM Trans Am and I currently have a Sunfire...

This problem accured on both my cars...This may sound silly and I don't expect you to do this with your Sky.....But when everything goes blank on the Sunfire Stereo I hit it with my palm and everything comes back on...sorta like when Han Solo hits the falcon to get the lights and engines working again....:lol:

This has to be a wireing problem...Keep an eye on that...I dont have a warrenty anymore so this is what I have to do without paying for it to get fixed...If this happened to my Sky I would bring it to the Dealership ASAP and take car of the problem!

:cool:
 

·
Registered
Joined
·
1,205 Posts
Thanks for the tip :lol: buttttt I think I will just let the dealer exchange it for a new one....
 

·
Registered
Joined
·
1,205 Posts
Jayne said:
I also took delivery of my Baby on the 12th. Could be a bad day for radio problems but one great day because we finally got into the drivers set. I'll see if the problem continues and then request that the radio be changed out. The on-star is great. I'm still in the learning process here. There are so many new and wonderful things to learn but time is really a problem...too busy driving :) Hope you are enjoying your Sky as much as I am. I wish I knew how to post pictures because I already gave my baby a pink heart, fairy decals and her name on the back of the windscreen "Corievette". Thanks for letting me know I was not alone.
Jayne
My pleasure. Now Ride Jayne, Ride......:driving:
 

·
Registered
Joined
·
669 Posts
I had that problem...but it was because I had somehow turned the light level switch down, probably with my knee...it's right there on the left side by the fog light switch. Sounds like your problem may be different, though. Just a heads up for those of us with long legs...

BTW, did you notice that when you use On-Star to make a call, the number you "dial" shows up on the radio screen? It doesn't on my son's ION or my wife's VUE.
 

·
Registered
Joined
·
102 Posts
New radio problem...

We picked up our car last week. We now have 1600 miles on it. The only "problem" seems to be a couple of instances where the radio and driver info display are dead for several minutes after the car is started. Not every time,,,,just done it twice in past 3 days. The only thing I observed was this took place when my husband tried the driver info button almost immediated after starting the car. Anyone have thoughts on this or had it happen? Thanks....Sheryl
 

·
Registered
Joined
·
1,298 Posts
qwack said:
I had that problem...but it was because I had somehow turned the light level switch down, probably with my knee...it's right there on the left side by the fog light switch. Sounds like your problem may be different, though. Just a heads up for those of us with long legs...

BTW, did you notice that when you use On-Star to make a call, the number you "dial" shows up on the radio screen? It doesn't on my son's ION or my wife's VUE.

WOW, I thought it was only me so I didn't say anything. I have the base stereo (single cd) and mine has done the blank screen thing twice. both times I reached down and adjusted the dimmer and it lit back up so I thought I must have bumped it. coincedence? or is it broken? hmmmmm
 

·
Registered
Joined
·
669 Posts
usmc said:
WOW, I thought it was only me so I didn't say anything. I have the base stereo (single cd) and mine has done the blank screen thing twice. both times I reached down and adjusted the dimmer and it lit back up so I thought I must have bumped it. coincedence? or is it broken? hmmmmm
:) Yeah...sometimes it takes a real man to admit he did something stupid. :D

(hope that's all it is.)
 

·
Registered
Joined
·
105 Posts
My car just started showing this symptom... blank radio display and info display, but it all works. It fixes itself after some time. Happened to me twice now, and I do NOT have the 6 disk changer. hmmm :banghead:
 

·
Registered
Joined
·
2,011 Posts
With the top down and the sun shining I can't see the radio or the DIC display. It could go on and off and I would never know it.
 

·
Registered
Joined
·
2,950 Posts
motocrash said:
My car just started showing this symptom... blank radio display and info display, but it all works. It fixes itself after some time. Happened to me twice now, and I do NOT have the 6 disk changer. hmmm :banghead:
Everyone be sure your interior instrument light adjustment is turned up, if it is turned down even when the lights are off it will turn off the radio display... Mine was that way when I picked it up...
it is possible when cleaning the instrument panel to accidently turn the knob...
not that i am saying that is the problem here but it is something to check each time it happens...
 

·
Registered
Joined
·
166 Posts
When I got my new Sierra it did this a couple times also. I think it's just another GM 'feature' somehow... It just happened once or twice then everything was fine again.
 

·
Registered
Joined
·
105 Posts
Ok, I am stupid... I figured it out. The brightness control was turned all the way down... so driving in the day it looks normal... but when I drove into the tunnel it eventually reached the brightness level that turned on the night mode, and the displays were too dim to read. Fixed itself when I got back into daylight. Same thing today as I started the car in the garage, then pulled out into sunlight. Doh! :jester: dunce cap for me!
 

·
Registered
Joined
·
2,011 Posts
Mine did it today. The radio and the DIC display went off for only a second and came right back on.
 

·
Registered
Joined
·
1,417 Posts
GaryH said:
Mine did it today. The radio and the DIC display went off for only a second and came right back on.
Were you by chance going under a long patch of trees or a tunnel when the blackout occurred? I just wonder if its not fully going out but just dimming to a point you can't see it (as mentioned in the above posts).
 

·
Registered
Joined
·
2,011 Posts
1994SC2 said:
Were you by chance going under a long patch of trees or a tunnel when the blackout occurred? I just wonder if its not fully going out but just dimming to a point you can't see it (as mentioned in the above posts).
Nope. In my driveway. The top was up and ac was on. No glare on the display. And not just the radio but the DIC also.
 

·
Registered
Joined
·
2,011 Posts
Ernest said:
Take it to the dealer if it ain't the dimmer, that is what the warranty is for, if it is a problem, they can repair it and report it to the engineers.
I think it may be the dimmer because the dimmer does nothing. I just came back from a short trip to the grocery and rolled the dimmer wheel back and forth and it does nothing. The display stays bright. So I'll take it in for service.
 
1 - 20 of 21 Posts
Top