Saturn Sky Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter #1
Hey guys I am having a hell of a time removing the IM. I have undone all of the intake, fuel pump stuff, vacuum, etc, as well as the IM fasteners themselves. There appears to be some support bar in the way...only site that mentions it is on the cobalt forum. I cant get the IM off the studs, it will not move enough and I am wary of putting a ton of force into it. I jacked the car up and looked around the starter and its a mess of wires and of course obfuscated by the starter. There has to be an easier way? What is the procedure?
 

·
Registered
Joined
·
532 Posts
Must be something else. When I pulled one, the worst parts were the HPFP shield and that support brace. Just wiggled it off the studs. Make sure you got all the bolts.
 

·
Registered
Joined
·
262 Posts
Discussion Starter #8 (Edited)
Back out there today and still wrestling with it. Am I reading right that nobody has had an issue with this support bar? Do you guys even have one? Maybe this was unique as mine is an early production 07?

edit: I finally was able to dig around and found the mounting bolt on the block is nestled behind the vacuum pump (im guessing?) and next to the crank sensor....I guess itll be a snake of extensions and u-joints to get to it, looks fun.
 

·
Registered
Joined
·
262 Posts
Discussion Starter #9
Job finished - realizrd the bracket with a couple fasteners (vac line, wire harness etc) was hung up on the stiff AC line running next to the IM. Even though the bracket runs pretty straight down the side of the IM, the clamps stick out pretty good...was a pain to get back on, but its done. Good riddance, not a job I want to do again but the crank sensor is replaced and running 100%.
 
1 - 10 of 10 Posts
Top