Saturn Sky Forum banner
121 - 140 of 166 Posts

· Premium Member
Joined
·
1,310 Posts
Discussion Starter · #121 · (Edited)
I got the hood sanded, but good lord is wrapping a hard skill to master...

Vehicle cover Vehicle Car Automotive lighting Hood


Mirrors and A pillar in matte black.

Automotive lighting Hood Automotive tire Vehicle Motor vehicle


I'm doing my best, but dang is this hard. Definitely will be a 20ft car at NASSAM.
I did purchase some wrap cut tape, which should make it lots easier.
 

· Premium Member
Joined
·
1,310 Posts
Discussion Starter · #128 ·
Welp, I'm just gutted.
I was doing rips during shakedown #2, and lost engine power. Originally I thought I had popped a charge tube off. It's throwing codes for low fuel rail pressure, and misfires on 1, 3, and 4.

I have no idea what happened, but I hope I can fix it. I'm currently thinking contamination in the e85 (clogging injectors), a bad wire connection to the fuel pump, or the new RPM HPFP went bad. It can still drive, and the turbo spools, but sounds off and drives slow.

Wheel Car Tire Land vehicle Vehicle
 

· Registered
Joined
·
1,019 Posts
Welp, I'm just gutted.
I was doing rips during shakedown #2, and lost engine power. Originally I thought I had popped a charge tube off. It's throwing codes for low fuel rail pressure, and misfires on 1, 3, and 4.

I have no idea what happened, but I hope I can fix it. I'm currently thinking contamination in the e85 (clogging injectors), a bad wire connection to the fuel pump, or the new RPM HPFP went bad. It can still drive, and the turbo spools, but sounds off and drives slow.

View attachment 119893
That sucks man! I’m guessing NASSAM this week won’t be in your future?
 

· Administrator
Joined
·
8,913 Posts
My apologies John. I think I misread your intial response as a misunderstanding.
No apology needed, my response was an attempt at humor that didn't work as intended.

I'm really sorry to hear that you are having problems with the car. I hope that the fuel problem turns out to be something simple.
 

· Premium Member
Joined
·
1,310 Posts
Discussion Starter · #136 ·
I ordered the ACDelco fuel pressure sensor. Amazon was the cheapest AND they're delivering it today.

Huge thanks to Ssky for bringing it up and Super Serg for looking it up in the manual. Y'all are amazing. I was in a pit of despair for a bit there.

My mates and I are all waiting for the Pikes Peak Hill Climb to start.

Sky Motor vehicle Plant Fog Asphalt
 

· Premium Member
Joined
·
1,310 Posts
Discussion Starter · #138 · (Edited)
I don’t remember if they are backwards compatible.
The sensor fits right in, and it is the original sensor from my old fuel rail.
I replaced it this morning, and it's still misfiring. The codes are slightly different though (before new fuel sensor):
Rectangle Font Screenshot Parallel Number

After new fuel sensor:
Rectangle Font Material property Screenshot Parallel


I would say the engine runs "smoother" now, but it's still running rough.
I did a scan and am sending it to ZZP.

My best guess right now is contaminants in the e85 that went into the injectors and fuel sensor, and bunged everything up. I totally thought of buying the ZZP fuel filter ages ago too...

I'll have to get a scope down the cylinders after I get back from NASSAM.
 
121 - 140 of 166 Posts
Top