Saturn Sky Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
Does anyone else have about 1-2 degrees of play in the steering wheel? Has always been like this since I got the car in 2015. Tie rods seem to be in great shape and don't think its the rack, it sounds more towards the cabin along the shaft rather than the usual suspects. It's also not the hub bolts. Maybe intermediate shaft or collapsing assembly?

What can be affordably replaced to make it less clunky and more responsive? It hasn't gotten worse over the years and had just chalked it up to being a GM vs import issue but after driving friends base model Solstice, I realized it's just my car.

Thanks in advance!
 

·
Registered
Joined
·
4,201 Posts
Yeah, that's not a normal situation. Sorry cannot help as to why, you've covered all the things I would suggest :(
 
  • Like
Reactions: a280z

·
Registered
Joined
·
758 Posts
All I can add is that our 2007 Base has no steering wheel play in it. So what you have does not seem normal to me either.
 

·
Registered
Joined
·
10 Posts
I had the exact same problem. Found out the lower u-joint on the intermediate shaft where it enters the rack was the problem. There is another u-joint where it attaches to the upper column under the dash. Also make sure the attachment bolt is tight also.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #6
I had the exact same problem. Found out the lower u-joint on the intermediate shaft where it enters the rack was the problem. There is another u-joint where it attaches to the upper column under the dash. Also make sure the attachment bolt is tight also.
Thanks! Will check these areas soon.
 
1 - 6 of 6 Posts
Top