Saturn Sky Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I have a '07 base Sky and it's been 100% trouble free for the last two years that I've owned it - but suddenly in the last month it seems to be falling apart. I have very little mechanical skills, so I'm planning on taking it to the old Saturn dealership locally (now a Suzuki dealership) but before I do so I'd love to get some feedback on the issues so I have a clue as to what is happening and I don't get taken for a ride.

Hood release broke - just happened the other day when I went to open to put in some wiper fluid. I pulled on it, and the hood on the left side barely popped open and then there was no tension on the handle. I didn't hear a snap or feel a snap, and now there is no tension on the handle. For the hood, it barely popped open, but wouldn't open all the way. I was able to close it - but I have no idea what to do to open it. I felt around under the dash and I think I feel the hood release cable, it's detached from the level I think, but if I pull on it, there's no tension to it. So I'm guessing it snapped. I did search and read what others said, but if anyone has any additional thoughts I'd welcome it.

Heater broke, fan works fine. I live in FL so I rarely need the heat other than to defog the windshield. Anyways it blows whatever the outside temp is, and the A/C works just fine. I did find an article talking about resetting the temp controls, I did that, got the blinding LEDs and such, but it didn't help. The car is running in the normal range as far as the temp goes, around 190 or so, creeping as high as 202 or so, which seems normal, so I don't think it's the coolant - not that I can check it since I can't open the hood. Again, any suggestions on this would be welcome.

Also the blinkers don't snap back into position. Not a big deal, but I might have it fixed if it's not a lot money. I believe it's blinker stalk - but I'm not sure. Again, any advice on what it might be would be helpful in case they feed me a line of bull as far as what could be wrong.

Also the rear trunk is difficult to open and won't pop up by itself at all - I need to grab and pull while releasing in order to get it to open. I'm guessing this is the springs - maybe - assuming there are springs. Again, this one isn't a big deal, it's sort of been like this since I had it, but I'd like to get it fixed so it works smoothly if it's not a lot of cash.

Finally, and this one is my fault, I wanted to replace the rear view mirror with an auto-dimming mirror. I saw you needed to repin the harness, not a big deal, I can handle that... well, except for the life of me I can not get those pins in the mirror harness to release no matter what I do. Is there a trick to it - or does it require a special tool? I gave up on it after a while and just put the original mirror back in, but from all the pulling and tugging the interior light now doesn't work. If I jiggle the harness it will come on for a moment - but that's it. the onstar and the other backlight buttons still work. I know I just need to reseat the pins, but again, I can not get them to release. Any advice on this will be helpful - but this shows how useless I am as far as mechanical skills go, which is why I'm just taking it into the shop.

If you made it this far, you're a great American. If anyone has an idea or a book on how many hours the things above might be to fix, that would be helpful info.

Thanks again.
 

·
Registered
Joined
·
3,974 Posts
I have a '07 base Sky and it's been 100% trouble free for the last two years that I've owned it - but suddenly in the last month it seems to be falling apart. I have very little mechanical skills, so I'm planning on taking it to the old Saturn dealership locally (now a Suzuki dealership) but before I do so I'd love to get some feedback on the issues so I have a clue as to what is happening and I don't get taken for a ride.

Hood release broke - just happened the other day when I went to open to put in some wiper fluid. I pulled on it, and the hood on the left side barely popped open and then there was no tension on the handle. I didn't hear a snap or feel a snap, and now there is no tension on the handle. For the hood, it barely popped open, but wouldn't open all the way. I was able to close it - but I have no idea what to do to open it. I felt around under the dash and I think I feel the hood release cable, it's detached from the level I think, but if I pull on it, there's no tension to it. So I'm guessing it snapped. I did search and read what others said, but if anyone has any additional thoughts I'd welcome it.
I can't help with this one - maybe someone else has experience.

Heater broke, fan works fine. I live in FL so I rarely need the heat other than to defog the windshield. Anyways it blows whatever the outside temp is, and the A/C works just fine. I did find an article talking about resetting the temp controls, I did that, got the blinding LEDs and such, but it didn't help. The car is running in the normal range as far as the temp goes, around 190 or so, creeping as high as 202 or so, which seems normal, so I don't think it's the coolant - not that I can check it since I can't open the hood. Again, any suggestions on this would be welcome.
Sounds like the blend door actuator. Reasonably common problem and I cheap DIY fix - though you have to be 'physically flexible' :) See: https://www.skyroadster.com/forums/f5/heater-controls-28861/index3.html#post918249 or do a search for more threads on this.


Also the blinkers don't snap back into position. Not a big deal, but I might have it fixed if it's not a lot money. I believe it's blinker stalk - but I'm not sure. Again, any advice on what it might be would be helpful in case they feed me a line of bull as far as what could be wrong.
Again reasonably common and easy/cheap DIY fix: https://www.youtube.com/watch?v=nRWlMUkTBaQ

Also the rear trunk is difficult to open and won't pop up by itself at all - I need to grab and pull while releasing in order to get it to open. I'm guessing this is the springs - maybe - assuming there are springs. Again, this one isn't a big deal, it's sort of been like this since I had it, but I'd like to get it fixed so it works smoothly if it's not a lot of cash.
Again reasonably common (though not as easy DIY). It's likely that one or both of your torsion bars (i.e. "springs") have broken and need to be replaced. Lots about it on google: https://www.google.com/search?q=saturn+sky+trunk+torsion+bar+site:www.skyroadster.com

Finally, and this one is my fault, I wanted to replace the rear view mirror with an auto-dimming mirror. I saw you needed to repin the harness, not a big deal, I can handle that... well, except for the life of me I can not get those pins in the mirror harness to release no matter what I do. Is there a trick to it - or does it require a special tool? I gave up on it after a while and just put the original mirror back in, but from all the pulling and tugging the interior light now doesn't work. If I jiggle the harness it will come on for a moment - but that's it. the onstar and the other backlight buttons still work. I know I just need to reseat the pins, but again, I can not get them to release. Any advice on this will be helpful - but this shows how useless I am as far as mechanical skills go, which is why I'm just taking it into the shop.

If you made it this far, you're a great American. If anyone has an idea or a book on how many hours the things above might be to fix, that would be helpful info.

Thanks again.
You have to lift the lock panel(s) on the connector first. I wrote a post on this, but can't find it now. Here's the pic though.. I just can't recall offhand if the pins just slide out after you lift the panel, or you still have to insert a dressmakerr's pin (or dental pick) into the relevant hole in the face of the connector to release each pin - but I suspect the latter:

 

·
Premium Member
Joined
·
1,293 Posts
Also the blinkers don't snap back into position. Not a big deal, but I might have it fixed if it's not a lot money. I believe it's blinker stalk - but I'm not sure. Again, any advice on what it might be would be helpful in case they feed me a line of bull as far as what could be wrong.
Easy fix... here is a post with the simplest way to replace on sky. No need to drop steering wheel.

https://www.skyroadster.com/forums/f5/how-remove-turn-indicator-stalk-saturn-sky-witout-dropping-steering-wheel-80377/
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4 (Edited)
Re: TomatoSoup

I've been out for Christmas but finally checking up on stuff - and thanks for posting this - I really appreciate giving ideas on each point. I still need to take it to the shop for the hood release, but I didn't realize the blinker stalk replacement would be fairly doable myself. Also I need to retry the pins on mirror again. I know that release latch is there, but I'm guessing I did something wrong and just need to take another run at it, it has to be something simple I'm just not not getting.

Oh and one thing I did after talking to a friend was go through the entire car and re-grease everything. This helped quite a bit with the trunk - it doesn't open up all the way or anything, but it's no longer a struggle just to get it to pop-up. When these were new would they actually open all the way by themselves?

Again thanks for the feedback, this is very useful.
 

·
Super Moderator
Joined
·
5,269 Posts
Mine never opened all the way by itself, but it would go up eight inches or so.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Mine never opened all the way by itself, but it would go up eight inches or so.
Perfect, thanks for the info. So it should go up a bit, but not open all the way. So basically it's good enough for now.

Since greasing everything up, it still doesn't really pop up much, maybe an inch (probably less), but now I can easily open it from either side and don't have to hit the release button multiple times. Before I had to do it by grabbing from under the passengers side while hitting the release button - and only the passengers side for some reason. I went through the entire car and just sprayed everything I could find - now the doors open easier, trunk opens easier, the top latch closes easier, it's really been a big improvement. I can't believe I never thought to do that before.

Whenever I finally get the hood release fixed I'll grease everything there as well.
 
1 - 7 of 7 Posts
Top