Saturn Sky Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello, how are you all,

I currently have a saturn sky 2.4L,

I have a problem with the air conditioning, the fans turn on but the compressor does not. The air is hot all the time, it does not cool. I've been reading and some people indicate that it may be the temperature sensor that is causing all of this. my car is very rare that it indicates the temperature, almost always the car indicates read this: --------- ºF

The air conditioner only cools down when I disconnect and connect the battery. it seems as if the system rebooted.

Other times I have accelerated my Saturn sky to over 150km and the air conditioning has started to cool down, I really don't know what's wrong with my car.

Yesterday I replaced the temperature sensor but it still does not read it, it remains the same: --------- ºF

It should be noted that my air conditioner has refrigerant in it.

If someone has had the same problem and found the solution, please tell me.
 

·
Premium Member
Joined
·
234 Posts
In the first few months of owning my Sky I wondered if my air conditioning worked.

So we're on the same page...

The left dial/button must be turned all the way to the left and pushed so the light comes on.

The middle dial/button must be turned (at least one click to the right) so the fan blows.

The light on the middle dial/button must NOT be turned on.

When the middle button light is on that allows air to flow into the car and that has the effect bringing in warm air.

--

I didn't know a temperature sensor has anything to do with it.

Wouldn't the next step be to confirm the refrigerant is good - not just that some exists?
 

·
Registered
Joined
·
3 Posts
In the first few months of owning my Sky I wondered if my air conditioning worked.

So we're on the same page...

The left dial/button must be turned all the way to the left and pushed so the light comes on.

The middle dial/button must be turned (at least one click to the right) so the fan blows.

The light on the middle dial/button must NOT be turned on.

When the middle button light is on that allows air to flow into the car and that has the effect bringing in warm air.

--

I didn't know a temperature sensor has anything to do with it.

Wouldn't the next step be to confirm the refrigerant is good - not just that some exists?
My battery died , nothing worked . Got a jump now Air conditioning does not work ! Coincidence? Or
 

·
Administrator
Joined
·
7,202 Posts
My battery died , nothing worked . Got a jump now Air conditioning does not work ! Coincidence? Or
Welcome to the forum.

Can you describe what your air conditioner is doing? "does not work" can have a lot of varaints.
 

·
Registered
Joined
·
1,108 Posts
my bad but what is the procedure u mention?
  1. Turn ON the ignition with the engine OFF.
  2. Turn the Temperature dial all the way to the right.
  3. Turn the blower control dial all the way to the right.
  4. Turn the mode position dial all the way to the left.
  5. Simultaneously press and hold the A/C and Defrost buttons until the LED's start to flash.
 
1 - 10 of 10 Posts
Top