Saturn Sky Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello everyone, this is my very first post since i joined the forum awhile ago. I purchased an 08 Sky Redline early July. Ive searched through many threads and various sites, but I haven't been able to find an answer to this issue. Are the turn signal lights suppose to stay on while the head lights are on? I installed led's all over and installed the kit from RPM Motorsports to make the side marker lights flash with the turn signal lights. I did the install immediately after buying the car, so I don't have a reference point to determine if the problem existed before then. I have checked all my wiring 3 times, the resistors for the LED's are installed correctly too. My turn signals and emergency flashers work like normal, but the passenger side turn signal light stays on and the driver side turn signal light stays off whenever the headlights are on. I have checked all the fuses and replaced all the relays associated with the lights. Anyone have any idea what this may be? My last guess is the BCM. I've spent so much on upgrades, I don't want to drop several hundred more to buy another BCM and get it programmed if i can avoid it. Thanks in advance for any help.
 

·
Registered
Joined
·
596 Posts
Hi sniickers,

I own a 2007 base so it wouldn't help to share how mine behaves. Keep in mind that I have no first hand experience with such a modification, but I offer some things to try.

  • Switch front-facing LEDs and see if the problem moves to the other side.
  • Switch side-facing LEDS...........
  • Switch both front and side-facing LEDs...........
  • Check the voltage at the suspect bulb socket to confirm you are getting zero volts to the light that is not turning on. Maybe you are getting just "UNDER" enough volts to activate the LED.
  • Do the pairs of lights blink in unison, or does the RPM kit have them blink alternating? Especially if they blink alternating, try switching the side-marker and front-facing light bulb connections.
  • Install both original incandescent right and left side turn signal bulbs and see if things work differently.
Again, I have no first-hand knowledge, just offering some general trouble-shooting tips.
 

·
Super Moderator
Joined
·
6,129 Posts
The problem is most likely with the side marker conversion.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Hi sniickers,

I own a 2007 base so it wouldn't help to share how mine behaves. Keep in mind that I have no first hand experience with such a modification, but I offer some things to try.

  • Switch front-facing LEDs and see if the problem moves to the other side.
  • Switch side-facing LEDS...........
  • Switch both front and side-facing LEDs...........
  • Check the voltage at the suspect bulb socket to confirm you are getting zero volts to the light that is not turning on. Maybe you are getting just "UNDER" enough volts to activate the LED.
  • Do the pairs of lights blink in unison, or does the RPM kit have them blink alternating? Especially if they blink alternating, try switching the side-marker and front-facing light bulb connections.
  • Install both original incandescent right and left side turn signal bulbs and see if things work differently.
Again, I have no first-hand knowledge, just offering some general trouble-shooting tips.
Thank you for the response. I have actually tried swapping the bulbs from left to right. I even placed the original bulb back in instead of the led and the problem remains. The kit does make the side marker light flash alternate from the turn signal light. I have checked the side marker kit wiring and it is connected correctly per the instructions. I am stomped. I guess I'll disconnect the side marker kit and see if that does anything. Thanks again.
 

·
Premium Member
Joined
·
4,193 Posts
Per John's comment above, try disconnecting the side marker light modification and see if the lights return to normal operation.
 

·
Registered
Joined
·
982 Posts
The mod can be dome without a "kit" simply by rewiring the light. If the mod was done before you installed the. "kit" from RPM things may well get messed up because the wiring isn't as stock.

As was suggested, maybe remove the "kit" and see where you are. Here is a link to perform the mod for no cost and with no additional parts, you don't need a "kit". The mod works with LEDs in the side markers as well and mine has worked fine since around 2008.

 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
I read up on that mod after I bought the kit. But a positive is the kit makes the side marker light blink alternating from the turn signal, instead at the same time. I personally think that's nice. I did end up purchasing a different set of led bulbs for the turn signal lights and now it works like it is suppose too. I didn't have to disconnect the RPM kit either. Turns out for the turn signal light, I needed a dual voltage led like the dual filament bulb it replaced. Thanks for the help everyone.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
Lol, well I thought all was well. I didn't notice that one light was flashing at two different brightness and the other light was turning on and off. I thought all was well since both lights came on and flashed, somehow I had missed the difference between them both.

So I went out this evening check the wires again and while reviewing the connections the ground wire broke due to the wire splice that came with the kit. So I decided do the install correctly and solder the connections. That did it. Back to my white LED front end! :D
 
1 - 10 of 10 Posts
Top